1

after dist-upgrade to 20.04, file sharing stopped working

now when i try to connect to another Ubuntu computer, it shows "Unable to mount location - Failed to retrieve share list from server: invalid argument"

how can we troubleshoot and fix this as simple and easily as possible? and how to prevent this happening again in the next dist-upgrade? i think i have both samba and smbclient installed

(i think i only used samba up to now, i have no idea how to configure nfs, afp or others as alternative network protocols since i never used them at home)

5

Are we talking about one Ubuntu 20.04 machine trying to connect to another 20.04 machine?

The problem is somewhat convoluted I'm afraid. Because of a bug in gvfsd-smb-browse the initial contact between client and server is with SMB1. But the version of samba in Ubuntu 20.04 disables SMB1 for security reasons. That is the reference to "invalid argument".

You have two choices:

[1] You could just override the default settings and re-enable SMB1 ( what samba calls NT1 ) on both machines:

Edit /etc/samba/smb.conf and right under the workgroup = WORKGROUP line add:

client min protocol = NT1
server min protocol = NT1

Then reboot the machine

[2] Or, you can leave things as they are by default and bypass gvfsd-smb-browse and connect to the server and its share directly in Connect to Server :

smb://hostname.local/share-name

The connection will be with SMB3.

There is actually a third option and that is a CIFS mount which you can add to /etc/fstab so that it mounts on access of its mount point. If you are interested I can show you how to do that.

2
  • thanks! the first choice seems simpler and worked perfectly fine! about cifs mount from /etc/fstab, i might take a look at it later when needed, thanks! – Paulo Silva Jun 16 '20 at 20:42
  • Great answer. My smartphones can connect again. But please do sudo service smbd restart. We are not Windows. My 12.04 lasted 9 months doing suspend/restore without reboot and my reboots are long. Alas, more recent releases crash. – Papou Feb 23 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.