I've recently installed Ubuntu 20.04 on my laptop only to find the touchpad didn't work, it is recognized in xinput and is turned on in settings. Which drivers can I install to make it work? (HP Pavilion 15 Gaming, Nvidia GeForce GTX 1050, AMD Ryzen 5)

Output of Xinput :

⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=15   [slave  pointer  (2)]
⎜   ↳ MOSART Semi. 2.4G Keyboard Mouse Consumer Control id=11   [slave  pointer  (2)]
⎜   ↳ MOSART Semi. 2.4G Keyboard Mouse          id=18   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ HP TrueVision HD Camera: HP Tru           id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
    ↳ HP Wireless hotkeys                       id=16   [slave  keyboard (3)]
    ↳ HP WMI hotkeys                            id=17   [slave  keyboard (3)]
    ↳ MOSART Semi. 2.4G Keyboard Mouse          id=9    [slave  keyboard (3)]
    ↳ MOSART Semi. 2.4G Keyboard Mouse System Control   id=10   [slave  keyboard (3)]
    ↳ MOSART Semi. 2.4G Keyboard Mouse Consumer Control id=12   [slave  keyboard (3)]

ssg-004@ssg-004-HP-Pavilion-Gaming-Laptop-15-ec0xxx:~$ xinput list-props 15
Device 'ETPS/2 Elantech Touchpad':
    Device Enabled (148):   1
    Coordinate Transformation Matrix (150): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Tapping Enabled (303): 1
    libinput Tapping Enabled Default (304): 0
    libinput Tapping Drag Enabled (305):    1
    libinput Tapping Drag Enabled Default (306):    1
    libinput Tapping Drag Lock Enabled (307):   0
    libinput Tapping Drag Lock Enabled Default (308):   0
    libinput Tapping Button Mapping Enabled (309):  1, 0
    libinput Tapping Button Mapping Default (310):  1, 0
    libinput Natural Scrolling Enabled (285):   1
    libinput Natural Scrolling Enabled Default (286):   0
    libinput Disable While Typing Enabled (311):    1
    libinput Disable While Typing Enabled Default (312):    1
    libinput Scroll Methods Available (287):    1, 1, 0
    libinput Scroll Method Enabled (288):   0, 1, 0
    libinput Scroll Method Enabled Default (289):   1, 0, 0
    libinput Click Methods Available (313): 1, 1
    libinput Click Method Enabled (314):    1, 0
    libinput Click Method Enabled Default (315):    1, 0
    libinput Middle Emulation Enabled (292):    0
    libinput Middle Emulation Enabled Default (293):    0
    libinput Accel Speed (294): 0.000000
    libinput Accel Speed Default (295): 0.000000
    libinput Left Handed Enabled (299): 0
    libinput Left Handed Enabled Default (300): 0
    libinput Send Events Modes Available (270): 1, 1
    libinput Send Events Mode Enabled (271):    0, 0
    libinput Send Events Mode Enabled Default (272):    0, 0
    Device Node (273):  "/dev/input/event10"
    Device Product ID (274):    2, 14
    libinput Drag Lock Buttons (301):   <no items>
    libinput Horizontal Scroll Enabled (302):   1

  • It depends on what is the touchpad. Elantech is not enough.
    – Pilot6
    Jun 16, 2020 at 10:51
  • Please edit your question and add output of xinput terminal command.
    – Pilot6
    Jun 16, 2020 at 10:52
  • 1
    ETPS/2 Elantech Touchpad
    – user1095545
    Jun 16, 2020 at 10:53
  • there i put the code in
    – user1095545
    Jun 16, 2020 at 10:59
  • Please now add output of xinput list-props 15
    – Pilot6
    Jun 16, 2020 at 10:59

6 Answers 6


Had the same issue on my HP Pavillion running Ubuntu 20.04. I spent two days looking for a solution.

The first thing that worked for me was editing the /etc/default/grub file:

GRUB_CMDLINE_LIN UX_DEFAULT="quiet splash psmouse.proto=bare"
GRUB_CMDLINE_LINUX="i8042.reset i8042.nomux i8042.nopnp i8042.noloop"

The link below has the full procedure: https://medium.com/@barcelos.ds/how-to-fix-touchpad-mouse-not-working-in-linux-operating-systems-b328bb43b4c5

After making those changes I could not use two-finger scrolling. To get that working I had to update the Linux kernel to version 5.10

The link below is what I followed to update the kernel: http://ubuntuhandbook.org/index.php/2020/12/install-linux-kernel-5-10-ubuntu-linux-mint/

Hope this helps.

  • It seems it works Feb 28, 2021 at 18:21
  • This partially worked. I can move the mouse and click with the touchpad, but not scroll (I am on Linux 5.11). The "Touchpad" settings program claims no touchpad was detected. Before I edited Grub, it was found there, but not working at all
    – Suppen
    Aug 3, 2021 at 14:03
  • So this is a solution, but it turns the touchpad into a mouse, so you lose all the nifty features like scrolling. That explains what you saw @Suppen
    – kingledion
    Aug 12, 2021 at 17:40

This is a kind of a bug in Ubuntu 20.04 where xorg-synaptics is in use when it shouldn't be.

This can be fixed by

sudo apt remove xserver-xorg-input-synaptics

The touchpad should start working with libinput after a logoff or reboot.

  • 1
    it still doesnt work
    – user1095545
    Jun 16, 2020 at 11:09
  • What does xinput list-props 15 show now?
    – Pilot6
    Jun 16, 2020 at 11:10
  • ive put it on the post
    – user1095545
    Jun 16, 2020 at 11:11
  • Hm. Now it is looking good. Then it is a kernel bug that this touchpad is not properly supported. There is a ton of different Elantech touchpads. Report it as a bug by ubuntu-bug linux.
    – Pilot6
    Jun 16, 2020 at 11:13
  • I have one that is working well.
    – Pilot6
    Jun 16, 2020 at 11:14

I had this problem. In the end what fixed it was upgrading the linux kernel through the HWE:

sudo apt install linux-generic-hwe-20.04

This brings in newer device drivers from the linux 5.11 kernel.

  • Most elegant answer that worked with single try Jun 14, 2022 at 20:10

I found this post that said to go into the boot menu and select the linux boot and it worked for me. However, you have to do this every time you reboot.


I've been using Ubuntu since 08.04 but don't consider myself 'knowledgable' on the subject. I have noted however that I suffered the same issues with my new HP laptop when I replaced Windows10 with Ubuntu 20.04. No touchpad detected ergo just no touchpad! I recently decided to dual boot Win10 & Ubuntu but the problem persisted until today. I selected UEFI Firmware Setup from the Grub menu. This took me to Windows Boot Manager where I selected Ubuntu.This took me back to the GRUB menu where I selected Ubuntu. Hey Presto, fully functioning Touchpad with one and two finger scrolling etc. Hope this helps someone else with similar setup to gain functionality. My motive was simply to get back to Ubuntu as I tired of Windows very quickly and just wanted to come 'home'.


@user491177 i cannot add a comment bc i have not enough reputation. I just created an account for your post :D I am searching for my touchpad problem for hours and couldnt find it. I have the exact same setup like you with the dual boot. So I go from grub to boot manager, select linux and then it works :D GJ!

You must log in to answer this question.