I'm using a TP-Link Archer T4U AC1200 V1 USB adapter. I'm on a fresh install of 16.04.6, and after running software update, installing a nVidia proprietary driver, I needed to install the driver for my USB WiFi adapter. I used the following driver and followed all the instructions in the readme for rtl8812AU_8821AU linux kernel driver for AC1200 (801.11ac) Wireless Dual-Band USB Adapter - GitHub

However, while my USB adapter is now recognized, it cannot connect to any of my home networks: Lim Family Fibre, LIMYPfamily 1 and LIMYPfamily 2. The symptoms are when I connect to a network and enter the password, it attempts to connect but never does, then prompts for the password again, without saying that an incorrect password was entered and with the password field already filled. When I click enter, the cycle repeats(cannot connect, prompts again)

I tried this: WifiDocs/WirelessTroubleShootingGuide/Drivers - Community Help Wiki

I have pasted the output of Wireless Info Script on pastebin.

1 Answer 1


In your paste, we see this:

Cell 01 - Address: <MAC 'LIMYPfamily1' [AC1]>
                    Protocol:IEEE 802.11bgn
                    Frequency:2.412 GHz (Channel 1)
                    Encryption key:on
                    Bit Rates:144 Mb/s
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    Quality=43/100  Signal level=47/100  

Most wireless drivers in Linux don't work very well with TKIP. In addition, it is the least secure of all the protocols available. This suggests that your routers are set to factory defaults which are neither as secure as possible nor Linux-friendly. I suggest a few tweaks.

WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I recommend a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

sudo nano /etc/default/crda

Change the last line to read:


Proofread carefully, save (Ctrl+o followed by Enter) and close (Ctrl+x) the text editor.

Is there any improvement?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .