How do I close the VLC? After closing VLC and opening it again, the process is still running on my taskbar. How do I close or end the process? enter image description here

  • Press Alt-F2 an run killall vlc.
    – pLumo
    Commented Jun 15, 2020 at 8:30
  • @pLumo, it didn't work. I also tried searching the web to find solutions, but somehow it wouldn't work. It seems like the only option I have is to close VLC through system monitor every time I want to close VLC.
    – clieg
    Commented Jun 15, 2020 at 8:32
  • 9
    What about killall -s 9 vlc ?
    – pLumo
    Commented Jun 15, 2020 at 8:33
  • It worked, thank you for your assistance.
    – clieg
    Commented Jun 15, 2020 at 8:37
  • Does the Quit-option from the dropdown menu (screenshot) not work?
    – mook765
    Commented Jun 15, 2020 at 8:40

6 Answers 6


Open "Run a command" window by pressing Alt+F2 or run the following from a terminal:

Try killall vlc to send SIGTERM to all instances of vlc (Tell em to terminate themselves).

If this does not work, try killall -s 9 vlc to send a SIGKILL (Tell the system to kill the processes).

  • Thank you. It solved my problem.
    – clieg
    Commented Jun 15, 2020 at 8:40
  • 2
    It's even better if you put that command killall -s 9 vlc in a hot corner. it's quicker ;) Commented Nov 4, 2020 at 23:50
  • This is not a permanent solution. It just kills the running process. Whenever you rerun vlc, the problem will persist. The solution provided by @forkirara is a permanent solution though.
    – Ombrophile
    Commented May 30, 2021 at 6:21
  • That is true, and I never said anything else. It is exactly the answer to the question. And git might be ood enough for people who have no general issue with that, but when it occurs just once in a while.
    – pLumo
    Commented May 31, 2021 at 8:43

I have resolved with this:

  1. Delete folder ~/.config/vlc.

  2. Open vlc.

  3. Open Preferences dialog, click on the Videos tab or button at the top. Then change your output to OpenGL video output.

  4. Then click on the Input / Codecs tab or button at the top, then change Hardware-accelerated decoding to Disable and then click the Save button.


  5. Close VLC Media Player.

  • 1
    Have tried this out and it actually solved the problem, VLC does now quit properly. Commented Mar 15, 2021 at 11:07
  • 1
    For me, step 4 (and step 2, obviously) was sufficient.
    – caw
    Commented May 28, 2021 at 18:55
  • 1
    This works at first, but when I close the window it still hangs again. I discovered that Menu> Media | quit closes the process, but simply clicking on the window close button causes it to hang, and then must be killed to get it re-start. Commented Oct 17, 2021 at 22:24
  • 1
    could someone explain exactly what this does and why it works? Commented Jun 19, 2022 at 14:52
  • This procedure works temporarily (VLC on Ubuntu 20.04), but the problem starts again after a week or so. The problem does not happen on VLC 3.0.16 on Ubuntu 22.04, so it's possible it's a VLC bug that got fixed in later versions.
    – JonahHuron
    Commented Nov 28, 2022 at 14:26

As an addendum to forkirara's answer, it seems that setting Video Output to 'XVideo output (XCB)' also works (tested on Ubuntu 20.04 and PopOS 20.04). This also seems to bypass the need to delete the VLC config folder.

(Sorry for responding as an answer, Stack Exchange forces you to do so until you get the right to make addendums properly as comments).

Hope this helps anyone else coming here because VLC still hasn't fixed this bug!

  • 2
    Also works. I also don''t understand why they don't fix this annoying bug Commented Feb 5, 2021 at 0:08
  • XCB output wroked.
    – Emvo
    Commented Mar 28, 2021 at 14:46
  • Worked for me on Ubuntu 20.04, changing to "OpenGL" didn't. Thank you.
    – Robin
    Commented May 10, 2021 at 20:32

As I, recently registered to this forum, I can't up-vote (or comment) any answers. So instead I'll mention it here besides a description of the behaviour on my machine.

First of all forkiraras answer works for me too. I think it should be preferred over killing processes - which isn't the intended way things should work.

Behaviour on my machine:

  1. opened vlc from file -> works
  2. click the x-button of the window -> window closes but vlc is still active in taskbar -> works, I guess
  3. selecting quit from the taskbar menu won't close vlc(-taskbar)
  4. selecting "show vlc media player" from the taskbar menu (1st entry) -> brings up the window again You can toggle the program between the window and minimized to taskbar this way.

So actually the program doesn't seem to be unresponsive, but simply won't (correctly) trigger the close-event (or whatever you want to call it).

  • 1
    Well.. It's a little more than that. Subsequent attempts to open video files (if you've got them set to open with VLC) will simply silently fail. Quite annoying. This started happening I BELIEVE after I swapped my nvidia card out for a much older AMD card. CPU decoding will be just fine...
    – Steven Lu
    Commented Jan 17, 2021 at 6:48

It appears this a known issue. All you have to do is go to tools > preferences > Input / Codecs and change the Hardware-accelerated codec to something other than Automatic or VDPAU.


  1. https://superuser.com/questions/1566707/ubuntu-20-04-vlc-player-not-quitting
  2. https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/1871949/comments/8

As Canonical seems not to be interested in providing an updated VLC-package (v3.0.9) for Ubuntu 20.04, I uninstalled the VLC package from the Ubuntu sources (apt purge vlc) and installed it again via the snapstore (snap install vlc). This worked perfectly for me, as this problem was fixed with VLC 3.0.12-3.

see: https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/1819543

  • 1
    Try also Flathub alternative. Almost everyone but Canonical move to flatpak, so probably will be better maintained. Here how to setup Commented May 2, 2022 at 18:54
  • @PabloBianchi I didn't know flathub at all. Thx for the recommendation!
    – Andy
    Commented May 4, 2022 at 11:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .