0

A bit of a backstory... I'm relatively new to using Ubuntu (maybe 2 years?).

I had always dualbooted before but recently I ditched Windows for Linux and installed Ubuntu 19.10 Eoan Ermie on my laptop. (I wanted to install Ubuntu 20.04 but the setup GUI never loaded and stayed black). I then updated Ubuntu 19.10 and used it for like a week before wanting to upgrade.

I ran all the commands to upgrade my current system then used do-release-upgrade to upgrade via the Terminal. It went smoothly until the end where it asked me to restart. I typed y and pressed ENTER. I knew something would go wrong when i started getting failed to write reg messages, then it wouldn't restart. It just showed the Ubuntu logo and did not turn off, nor restart.

Would it help if I mention that my Ubuntu 19.10 was encrypted?

I force shutdown and turned on my PC. It booted and asked me for my password that will un-encrypt the drive.

I entered it in and it said it was successful, then I saw a black screen with a unmoveable mouse cursor.

I waited for like 30 minutes before shutting my laptop down and booting off Ubuntu 19.10 Live Usb. It said it could not detect any Operating Systems so the OS would have quite possibly been corrupted after the upgrade. I just reinstalled 19.10 and had just finished reinstalling all my applications.

This had happened to me before once and I left it and decided to try it again now. I searched the internet for a solution but never found one. Am I doing something wrong? If so, what can I do to do it the correct way?

Note: I cannot install it via a live boot method like a live usb because, even after installing the image multiple times from the Ubuntu website, the setup GUI never loads and stays black.

If you have a solution, it would be helpful to keep all my files and packages whilst upgrading.

I'm sorry if I am asking too much, and I hope you can help! :)

10
  • 2
    Does this answer your question? My computer boots to a black screen, what options do I have to fix it? – user535733 Jun 14 '20 at 21:00
  • i have read that post before when i first got that problem and it didnt answer my question. you see- i cant access the grub menu during boot or any of the tty termianls. Thanks for your suggestion, though! – corrupt_disk1 Jun 14 '20 at 21:04
  • "cant access the grub menu"? Why not? Is something wrong with your keyboard? Have you tried the common answers? – user535733 Jun 14 '20 at 21:08
  • i followed everythin in this article linuxconfig.org/how-to-upgrade-ubuntu-to-20-04-lts-focal-fossa and i mean cant access the grub menu as in it wasnt showing me what os to choose to boot to like it would – corrupt_disk1 Jun 14 '20 at 21:12
  • if it helps, when i upgraded in the terminal - it says that there were possible missing firmware for my gpu. i didnt know where to get that firmware so i ignored it. – corrupt_disk1 Jun 14 '20 at 21:20
0

Thanks for your help! I have successfully managed to upgrade to ubuntu 20.04 while keeping my files and packages.

I did it accidentally, I was trying to repair a package by using the command sudo apt-get update and then sudo apt-get upgrade and Ubuntu just started to upgrade to 20.04 even though I just wanted my packages upgraded. I checked /etc/os-release and it said VERSION="20.04 LTS (Focal Fossa)".

Now because I only upgraded some packages, software updator told me that the upgrade wasn't finished even though the command exited. So, I clicked upgrade.

Now, everything works fine. I dont know what the problem was, but I ran fsck from a live media, upgraded my packages and tried to find firmware for my gpu (I couldn't).

Thanks for your help and suggestions!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.