4

Whenever I shut down my Ubuntu 20.04 and reboot, I always get this message at the bottom of my screen:

Press Ctrl+C to cancel all filesystem checks in progress 

This process will take too long and press Ctrl+C does not have any effect.

How to bypass it?

enter image description here

  • shutdown time is it showing?? 0r a fresh start n reboot time?? – UnKNOWn Jun 14 at 3:40
  • 1
    Are you shutting down the machine cleanly? A fsck should only occur after a configured number of boots (eg. 30) or a problem was detected last shutdown (eg. power outage or system forced off before shutdown completed) – guiverc Jun 14 at 3:50
  • @user535733 The file system check is a bug in 20.04, see: bugs.launchpad.net/ubuntu/+source/casper/+bug/1875548 – C.S.Cameron Jun 14 at 7:23
  • 2
    @karel: I still don't see an answer on that page, (except mine), that answers the question on this page. There is the link to the manpages that mentions fsck.mode, but the manpages do not spell out a solution that a new user can use. The Question is over four years old and refers to 16.04. This bug is specific to 20.04. – C.S.Cameron Jun 15 at 1:18
5

Removing Disk Check From 20.04 Boot

The command line option fsck.mode=skip can be used to skip the disk check when booting Ubuntu 20.04.

The line Checking disks: 0% complete may still come up but fsck will not be run, nor will boot time be increased.

Add fsck.mode=skip to the linux line in grub.cfg just before quiet splash

It is recommended to add the command to grub.cfg by editing /etc/default/grub thus: GRUB_CMDLINE_LINUX_DEFAULT="fsck.mode=skip quiet splash" and then run sudo update-grub.

I have had this problem with a Live USB but not with an installed system.

| improve this answer | |
  • Thanks, @C.S.Cameron. That works for me! – Penny Liu Jun 15 at 3:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.