I know there are many questions about this, but no one works for me.

I have been more than a week testing blogs, github and forum solutions, actually I really don't know what I have installed, blacklisted and created to try to get back my wifi adapter.

Problem started after I connect my ipad to my laptop.

Manufacturer: Dell Inc. Product Name: Inspiron 3521

Kernel release:


If I throw this line:

lspci -knn | grep Net -A3; rfkill list


02:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    Subsystem: Dell Wireless 1704 802.11n + BT 4.0 [1028:0016]
    Kernel modules: bcma, wl
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

If I throw this line

sudo modprobe wl


modprobe: FATAL: Module wl not found in directory /lib/modules/5.4.0-37-generic

If I throw this line:

grep wl /etc/modprobe.d/*


/etc/modprobe.d/iwlwifi.conf:# /etc/modprobe.d/iwlwifi.conf
/etc/modprobe.d/iwlwifi.conf:# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
/etc/modprobe.d/iwlwifi.conf:# microcode file installed on the system.  When removing iwlwifi, first
/etc/modprobe.d/iwlwifi.conf:# remove the iwl?vm module and then iwlwifi.
/etc/modprobe.d/iwlwifi.conf:remove iwlwifi \
/etc/modprobe.d/iwlwifi.conf:(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
/etc/modprobe.d/RTL810xE.conf:options RTL810xE fwlps=N


secure boot disable
load legacy option Enable
Boot list option legacy

Secure Boot not enabled on this system. Done.

if I throw sudo apt install --reinstall bcmwl-kernel-source:

Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.4.0-37-generic/updates/dkms/


DKMS: install completed.
update-initramfs: deferring update (trigger activated)
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for initramfs-tools (0.136ubuntu6) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-37-generic

Anyone could help me?

  • So does sudo modprobe wl work now? The wl.ko is definitely there now. Reboot and Wi-Fi should work.
    – Pilot6
    Jun 14, 2020 at 20:48
  • man, please, give me your contact, you solve the problem, you are an amazing person, an amazing profesional, I really need to THANK YOU with some donation, i do not have words for you, you fix it!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    – titoih
    Jun 14, 2020 at 20:50
  • You are welcome.
    – Pilot6
    Jun 14, 2020 at 21:17

4 Answers 4


The driver is installed it is shown here:

Kernel modules: bcma, wl

wl is the correct driver for this adapter.

But the problem it is not in use. The reason may be that Secure Boot is enabled in UEFI settings, or it is blacklisted.

Check if Secure Boot is disabled in UEFI aka BIOS. If that doesn't help, run

grep wl /etc/modprobe.d/*

and look if wl is blacklisted somewhere.

If that doesn't help, reinstall wl by

sudo apt install --reinstall bcmwl-kernel-source
  • I reinstalled, it doesn't work
    – titoih
    Jun 14, 2020 at 19:33
  • What did you re-install? I didn't suggest to reinstall anything. Is Secure Boot disabled?
    – Pilot6
    Jun 14, 2020 at 19:36
  • secure boot is disabled. just letting know, that even reinstalling my OS wifi adapter is not found. 0: hci0: Bluetooth Soft blocked: no Hard blocked: no lo no wireless extensions. enp1s0 no wireless extensions.
    – titoih
    Jun 14, 2020 at 19:44
  • Run sudo apt install --reinstall bcmwl-kernel-source and post the output to your question.
    – Pilot6
    Jun 14, 2020 at 19:46
  • sudo apt install --reinstall bcmwl-kernel-source works for my Dell Vostro 3446. Nov 8, 2020 at 18:36

I was facing the same issue. came across this ticket. But for my device(Dell Inspiron 3543 & Unbuntu 20.04)

Kernel : 5.8.0-34-generic

BIOS : Secure boot disable

lspci -knn | grep Net -A3; rfkill list

06:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    Subsystem: Dell Wireless 1704 802.11n + BT 4.0 [1028:0016]
    Kernel modules: bcma
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Kernel module wl was missing

Tried : sudo apt-get install bcmwl-kernel-source

but still Kernel module wl was not installed, nor was my wifi working

bcma module was blacklisted. commented it in the blacklist.conf file, but no luck with the wifi.

Finally, this helped [https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1906745]


  1. sudo apt-get purge bcmwl-kernel-source

  2. sudo apt-get install broadcom-sta-source broadcom-sta-dkms broadcom-sta-common

  3. reboot

I'm not expert in this field, but this solution worked for me.


I tried many other solutions, but nothing worked for me.

In my case, I unchecked and re-checked WLAN option in my Dell Probook BIOS. I think some update to my BIOS messed up the things. After I rechecked the WLAN option, Wifi came in Ubuntu 21.04


I also face the problem.I solved this via "Additional Drivers" tab in "Software&update". Here already selected "Do not use the device"
Now u select " Using 802.11 Linux STA wireless driver source from bcmwl-kernel-source(proprietary)" click "Apply changes"


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .