3

Is there a single command to simply disable the "out-of-focus" effect? In Dconf manager I only see different setups for this behavior but none to just disable it.

0
5

In Gnome Shell, there are three possible window focus modes, (from dconf-editor) 1) “click” means windows must be clicked in order to focus them, 2) “sloppy” means windows are focused when the mouse enters the window, and 3) “mouse” means windows are focused when the mouse enters the window and unfocused when the mouse leaves the window. Thus, to disable the focus follows mouse, you need to set it to "click":

gsettings set org.gnome.desktop.wm.preferences focus-mode 'click'

This is actually the default setting in Ubuntu and in many Gnome Shell installations. So also the command

gsettings reset org.gnome.desktop.wm.preferences focus-mode

would usually revert to the "click" setting.

This setting is also exposed in the utility Gnome Tweaks (Windows tab). It is not installed by default in Ubuntu.

2
  • Thank you, but I had already tried these and the out-of-focus effect does not stop - actually I do not care if it follows or not the mouse, just stopping part of the screen getting out of focus (I have poor eye-sight, this out of focus is unnecessarily tiring to my eyes)
    – olav
    Jun 14 '20 at 7:33
  • I guess that in that case, I have difficulties understanding your specific issue. You may be referring to the fact that a window gets less black when it does not have the focus? Please edit your post to be more specific about your problem. The title may be misleading.
    – vanadium
    Jun 14 '20 at 8:25
0

As vanadium guessed, I was on the wrong track with "focus follows mouse". I now think that the dysfunction I was having is better described as "blurry display" due to some anti-aliasing settings in the NVIDIA X Server Settings.

1
  • If you have fixed the problem by changing the necessary anti-aliasing option in the NVIDIA X Server Settings, then please edit the answer and add the changes you made that lead to the solution to help future readers.
    – pomsky
    Jul 4 '20 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.