2

I have been able to successfully boot various 20.04 ISO's such as kubuntu-20.04-desktop-amd64.iso from my hard drive using GRUB2. However, I have not been able to get the persistent kernel option to do anything.

My basic steps:

  1. Download kubuntu-20.04-desktop-amd64.iso as /home/me/Downloads/ISO/kubuntu-20.04-desktop-amd64.iso
  2. Created casper (now named writable) file by running the following:
sudo dd if=/dev/zero of=writable bs=1M count=1024
sudo mkfs.ext4 -L writable -F writable
  1. Used grub-customizer to create the following entry in my /etc/grub.d/40_custom file, update grub.cfg, etc.
menuentry "ISO-Kubuntu-20.04"{
        set root='(hd1,2)'
        search --no-floppy --fs-uuid --set=root 89a8c109-4b01-4ff9-88c7-17a371cad718
        loopback loop /home/me/Downloads/ISO/kubuntu-20.04-desktop-amd64.iso
        linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=/home/me/Downloads/ISO/kubuntu-20.04-desktop-amd64.iso nosplash debug --verbose fsck.mode=skip persistent locale=en_US bootkbd=us console-setup/layoutcode=us noeject --
        initrd (loop)/casper/initrd

I have tried this with the writable file in various places including root of the drive and /home/me/Downloads/ISO/, where the ISO's are stored. I have also tried various attempts at using the persistent-path parameter, all to no avail.

Note: I do not have enough reputation points to comment on the similar How to create pesistence storage for ubuntu live boot? post. And, I obviously do not have an answer to post there.

grub-install -V reports grub-install (GRUB) 2.02-2ubuntu8.13 on my system.

I am running Kubuntu 18.04.3 LTS.

Any specific suggestions would be appreciated. And, I am more than happy to post additional information if there are other items that would be helpful.

Thank you.

3
  • On the linux line of grub.cfg you need to give the persistent-path to the uniquely named folder that holds the casper-rw, writable or home-rw persistence files. ie ... persistent persistent-path=18.04.2 .... I will try to find an old Ask Ubuntu answer that gives details. see: askubuntu.com/questions/962536/… Jun 13 '20 at 3:30
  • The main point is that the persistence file must be located on a FAT32 partition, (just like UNetbootin's or Universal's casper-rw file). If you only need one case of persistence, you can create an ext4, casper-rw Persistent partition. Jun 14 '20 at 2:17
  • C.S.Cameron, Thank you very much for the quick, thorough, and accurate response. I had misunderstood the advice I had read to use ext4 for persistence files (casper-rw, home-rw, writable, etc.) on a HDD and did not realize these still had to be on a FAT32 partition. Once I moved the directories containing my persistence files files to a FAT32 partition, everything worked like a charm. Again, thank you!
    – jgrussell
    Jun 15 '20 at 16:37
1

Multi-Persistence Booting ISO's from HDD

For Ubuntu Flavors, Debian, LinuxMint, Elementary OS and Zorin, you can have as many Persistence files as Live OS, more even.

You can put the ISO files in a folder on an ext4 or NTFS partition. A NTFS partition allows Windows to have access to them.

The Persistence files must be located on a FAT32 partition.

Each Persistence file(s) must have it's own uniquely named folder. You can have both a casper-rw, (or writable) file and a home-rw file in each folder for a total of 8GB.

Sample grub.cfg Menuentry

 rmmod tpm
menuentry "ubuntu-20.04-desktop-amd64.iso" {
    set root=(hd0,1)
    set isofile="/isos/ubuntu-20.04-desktop-amd64.iso"
        loopback loop $isofile
        linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=$isofile persistent persistent-path=/Ubtu-20.04-4/ splash --
        initrd (loop)/casper/initrd
    }

Where the ISO file is located in the isos folder in the root partition and the corresponding casper-rw file is located in the persistence folder, Ubtu-20.04-4, on a FAT32 partition. The name of the FAT32 partition does not need to be mentioned in persistent-path.

Edit:

Ubuntu 19.10 and 20.04 use GRUB 2.04 when booting in UEFI mode. GRUB 2.04 has problems booting ISO files. A workaround is to add rmmod tpm above the first menuentry in grub.cfg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.