You might think this is an Android related question, but, I tried building my Android app on Eclipse in 12.04, and it just dont work. It doesnt generate R.java. The same problem is happening to IntelliJ.

The app was working correctly when I was using another OS, now with 12.04 it just doesnt work. Would it be the Eclipse, or some compiler problem?

I'm using the Eclipse downloaded from Ubuntu Software Center, which is Indigo.

12.04 have some restriction related to Android, or Eclipse, IntelliJ, everything related to Java compiler associated with Android?



First, please don't cross-post

Your restriction question
It has to do with weird licensing issues and/or closed source parts.
The openJDK works just fine for a great deal more than it used to.
If people use it and troubleshoot bugs, it can only get better.
It's not Ubuntu's fault. Get the other guys to change their licensing restrictions.

Now let's get it working
If it's not working and you think you tried everything, first blow out your eclipse installation(un-install and re-install).
If removing and re-installing plug-ins doesn't work, rename your ~/.eclipse folder and start again.
If that doesn't work, delete the .metadata folder in workspace...and start again.
(you're going to have to re-import all your projects)

Install Eclipse from repository(I'm using eclipse from software center and the openJDK).
If you're running x64: sudo apt-get install ia32-libs-multiarch

As root launch eclipse to get the latest platform/PDT updates(they're in /usr somewhere, so you need to be root).
Close eclipse(optionally delete the /root/.eclipse folder).

Launch eclipse as non-root.
Install plug-ins. They'll be in your ~/.eclipse directory.

If it's already installed
Remove all the components in Window->Android Manager
Update the plug-in through:
Help->Install Software->Already installed -> Show updates -> Install
Re-install all the components.

If it's not already installed
Install the ADT plugin through the Help install software menu. With this link.
Choose to install the SDKs during the ADT install.
If any part of installing gives you errors, un-install and install that part.

Install all the updates.
If any part of updating gives you errors, un-install and install that part.

This achieves the results below.
yes it works
version numbers

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.