0

Until this morning I had xubuntu 16.04 with kernel vers. 4.6.0 running without any problems on my Lenovo ThinkPad X1 (3rd generation). Because the system didn't stop nagging me to upgrade to 18.04 I did just that using the "software updater tool". I already did this some times, never with any problems at all.

After the release upgrade had finished and booting into the new kernel (4.15) the system seemed completely unresponsive. I couldn't click or do anything. But when I changed to tty1 by hitting STRGALTF1 I saw the login prompt and after that the shell is continously spilled with ^@ symbols. When I hit some keys here, the symbols sometimes change for a time and I am not able to get back to tty7 (where my desktop manager runs).

Now when I boot into the old kernel (4.6.0) I have the same behavior, and when I then go to tty1 I get the ^@ again but at least I can change back to tty7 and everything works "normal" … uuh well, sometimes I can't right-click things, sometimes things take unusually long, sometimes windows that I click don't get a focus and stuff like that. But at least it works, so I am able to post here.

During the release upgrade I was asked two times if I would keep the old configuration or if I want the maintainers version. That was with "unattended-upgrades" and "network-manager" and both times I hit "maintainers version" which I think might have resulted in this problem (not sure!).

I had a fully configured and running wwan interface with SIM card and everything which I had configured not to be enabled on start-up but only if I say so. This configuration has gone. To make sure that it isn't the wwan interface I installed tlp and did wwan off. This seems to have worked, but the strange behavior persists.

I also noticed that during the upgrade there where some warnings related to light-dm but they were to fast to read them. Yet another thing that I noticed was that the GRUB_CMDLINE_LINUX which I had to modify in some way a few years back when I installed the system was also gone, it is now only GRUB_CMDLINE_LINUX="". I searched the well-known sites dealing with ubuntu on thinkpad (including this site) but found nothing helpful. I can't find any site dealing with this problem I have, e.g. when I search "^@" google asks me to make sure that all words are written correctly.

To be clear, everything else seems to work, volume- and brightness keys, touchpad and so on, but only when I boot into kernel 4.6.0, open tty1 and let the symbols roll and then change back to my GUI on tty7.

I'm not sure what to try next, has anyone maybe a clue? Right now I'm again not able to focus other windows (e.g. the terminal emulator), I can only do so with ALTTAB. When I started to write this post it still worked. I would be grateful to get some help!

Update I just tried a

sudo apt-get update && sudo apt-get dist-upgrade && sudo apt-get install -f

– to no avail.

Also, man pages don't work anymore, they are completely empty, e.g. man ls: empty man ls page

I also did a

grep -ai "error" /var/log/syslog
Jun 12 16:24:32 denkbrett lircd-0.10.0[1155]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*

I disabled lircd like this:

sudo systemctl stop lircd.socket lircd.service
sudo systemctl disable lircd.socket lircd.service

Again, to no avail. I can't seem to find any other errors in the syslog. Am I missing something?

0

This issue could be solved by

purging lirc which constantly fired the error mentioned in my question:

sudo apt-get remove --purge lirc
sudo apt-get autoremove

and re-installing lightdm which gave a lot of warnings during the release upgrade

 sudo apt install --reinstall lightdm

After a reboot everything was fine.

Regarding the empty man pages I followed another post here and re-installed groff:

 sudo apt-get --reinstall install groff groff-base

I think that lirc caused the tty to be messed up with ^@. But I'm still not sure, so if anyone has a clue I'd be interested to hear. Thanks for your attention!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.