I am trying to run code-server on my ubuntu 18.04 vps. I managed to run it with an older version, but I had a lot of memory leak, and I switched to 3.2.0 code-server.

The issue now is that when I run it on the port I want to (or any port) the website won't open.

For example, if extract the tar, and I run code-server --port 8443 I get this error:

info  code-server 3.2.0 fd36a99a4c78669970ebc4eb05768293b657716f
info  HTTP server listening on
info    - Password is `somepassword`
info      - To use your own password set the PASSWORD environment variable
info      - To disable use `--auth none`
info    - Not serving HTTPS
info  Automatic updates are enabled

1 Answer 1


The code server is listening on, which means it will only be accessible from inside the VPS. If you want it to be accessible from the outside world, you could use a reverse proxy like nginx, or port-forwarding. There is a good guide here.

Here is a brief guide on how to do the port-forwarding with SSH:

  1. While logged in to your VPS by SSH, press Enter ~ C
  2. Type -R127.0.0.1:8443: and press enter
  3. The code-server will now be accessible on the machine you are connecting from by SSH at
  • This does not help me. I still can't access IP:8443.
    – Lmao 123
    Jun 12, 2020 at 11:06
  • No, after doing this you then access not <VPS public ip>:8443, from the machine you're connecting SSH from.
    – retnikt
    Jun 12, 2020 at 14:21
  • I'm buying a virtual private server. I can't connect to its localhost.
    – Lmao 123
    Jun 12, 2020 at 15:57
  • No, after forwarding the port with SSH, you connect to localhost on your computer, as in the one you typed this comment on.
    – retnikt
    Jun 12, 2020 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.