11

I recently updated to 20.04 LTS from 18.04 LTS.
When my system is up for like a day, alt-tab starts to lag. Not the window switcher panel, but when I select the window I want and release keys, it takes maybe a second to switch.

Rebooting or restarting gnome with killall -SIGQUIT gnome-shell fixes it back.
I also noticed gnome-shell was constantly at ~10% CPU while after restart, it's ~3%. Not sure if related.

I couldn't find anything about this problem. Any ideass on how can I fix, or further troubleshoot this?

GNOME Shell 3.36.2
nvidia-driver-440
5.5.13-050513-generic

4
  • I have the same issue, I believe it might be related to the nvidia drivers. Currently downgrading to 390 to see if that helps – BenSower Oct 6 '20 at 9:32
  • 2
    killall works! Thank you so much! – darw Nov 10 '20 at 15:48
  • I don't have nvdia and I also have this issue. I'm on Radeon vega graphics AMD chip. by the way thanks for the killall trick. you saving my life. I am not using the proprietary drivers in my case. i will install them and see what happens. – Nicholas DiPiazza Dec 12 '20 at 4:33
  • 2
    You can also restart gnome via Alt+F2 -> type "r" -> Enter -> Boom. Seems like a Gnome bug. – Íhor Mé Feb 20 at 9:55
0

I just had the same issue after migrating from 18.04 to 20.04, but I am using lightdm. Downgrading the nvidia-driver to 390 and restarting my machine solved the issue.

You can follow this link on how to update your drivers, but instead of the newest, choose an older one.

I only tried 390 so far, but a newer version might work as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.