0

Perhaps similar to Black screen after selecting an option from grub boot menu, but i was using a different graphical theme that worked until rebooting Ubuntu 20.04 after an update. Selecting a graphical boot option only shows a black rectangle. Can i fix it from this grub terminal?

GRUB won't boot OS options in Ubuntu 20.04

Somehow i got the old theme after leaving the rescue console, but that didn't show any options. Reboot, new theme, advanced Ubuntu with older kernel (5.4.0-34-generic (recovery mode)) is stuck at "Loading initial ramdisk ..." so Ubuntu 16.04 fails to boot 'Loading initial ramdisk' might help.

Power on, F12 on this XPS13, Fedora, brings up the old and working graphical GRUB menu (from the grub cfg in the efi folder). Fedora 32 boots just fine, as does Ubuntu 20.04. I ran the same system update that included grub2 on Fedora 32 and even grub2-mkconfig again, but a normal boot still leads to the broken new palm theme that doesn't even list kernel versions in its advanced menu for Fedora (neither does the old theme, though).

0

I managed to boot Ubuntu on this XPS13 by pressing F12 at the Dell screen after power on, and fixed the GRUB issue using:

$ sudo nano /etc/default/grub

Comment out or remove the broken theme line:

#GRUB_THEME="/boot/grub/themes/Crunchy-simple/theme-tropical.txt"

Optionally use a working theme.

GRUB_THEME="/boot/grub/themes/dark_squares/theme.txt"

Ensure readable GRUB menu on QFHD screen:

GRUB_GFXMODE="1024x768"
GRUB_CMDLINE_LINUX_DEFAULT="video=1280x720"

Ctrl+X and answer Yes to save and exit Nano.

Optionally remove some old kernel GRUB menu entries and free up /boot space after updating to the latest kernel in Synaptic:

$ sudo apt autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED
  linux-headers-5.4.0-31 linux-headers-5.4.0-31-generic linux-headers-5.4.0-34 linux-headers-5.4.0-34-generic linux-image-5.4.0-31-generic linux-image-5.4.0-34-generic linux-modules-5.4.0-31-generic
  linux-modules-5.4.0-34-generic linux-modules-extra-5.4.0-31-generic linux-modules-extra-5.4.0-34-generic
0 to upgrade, 0 to newly install, 10 to remove and 0 not to upgrade.
After this operation, 718 MB disk space will be freed.
Do you want to continue? [Y/n] 

The rest can be cleaned up manually.

Use working GRUB config for this OS:

$ sudo update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found theme: /boot/grub/themes/dark_squares/theme.txt
Found linux image: /boot/vmlinuz-5.4.0-38-generic
Found initrd image: /boot/initrd.img-5.4.0-38-generic
Found linux image: /boot/vmlinuz-5.4.0-37-generic
Found initrd image: /boot/initrd.img-5.4.0-37-generic
Found linux image: /boot/vmlinuz-5.4.0-32-generic
Found initrd image: /boot/initrd.img-5.4.0-32-generic
Found Fedora 32 (Workstation Edition) on /dev/mapper/fedora_localhost--live-root
Adding boot menu entry for UEFI Firmware Settings
done
$ reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.