0

I'm a new comer to Linux. I'm going to install Lubuntu (which is the best for my PC specs). Now the problem is how do I connect to internet.

I don’t have a WiFi connection. I connect to internet by my dongle (a Huawei dongle and it is customized by MOBILY 4G).

It works fine with Windows because the it has a .exe file to install the software. But in Linux I can’t install .exe files without something like wine.(As I know)

So what can I do?

Model number of my dongle - E3276s - 920

Also mention how can I update my drivers. (The transparency effects don’t work.)

3
  • Also asked at discourse.lubuntu.me/t/… – guiverc Jun 11 '20 at 6:33
  • 1
    Since this is an already tested and working USB modem, have you tried simply plugging it in while running Lubuntu to see if it works? You can test with a bootable USB stick. I've used several Huawei 4G USB modems and they 'just work'. Ubuntu recognized it as a modem and it connected immediately. If you change SIMs, visit 192.168.8.1 for its settings page (check the documentation but that's probably the address). – Tom Brossman Jun 11 '20 at 7:36
  • Thnx for your support. – shehan hashera Jun 11 '20 at 8:23
1

Welcome to Ubuntu. First of all I brief you about the fact that Wine in Ubuntu or any or Linux distro is a compatibility layer capable of running Windows applications. You need not to install any .exe driver in Ubuntu.

  1. First install modeswitch. Open terminal(CtrlAltT) and type

    sudo apt-get update     
    sudo apt-get -y install usb-modeswitch
    

    It will ask for your password. enter password. After that plug in your usb modem and run following command in terminal:

    lsusb
    

    Now your modem should be present in the list.

    Here is the further solution to add your modem as modem shared by johado in this post for

    Open terminal and type

    sudo nano /lib/udev/rules.d/70-usb-modeswitch.rules
    

    after this open in terminal copy and past following line(note in terminal you have to use CtrlShiftV to paste) and press CtrlS to save.

    # custom udev rules for UMTS modems
    ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="14fe", RUN+="/usr/sbin/usb_modeswitch -v 12d1 -p 14fe -M '55534243123456780000000000000011062000000100000000000000000000'"
    
    
    ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1506", RUN+="/bin/bash -c 'modprobe option && echo 12d1 1506 > /sys/bus/usb-serial/drivers/option1/new_id 
    

    I saved this as /lib/udev/rules.d/70-usb-modeswitch.rules.

  2. For updating your driver and software run following in terminal CtrlAltT

    sudo apt-get update --fix-missing
    

    then update software from update manager.

11
  • Thanks for your support. – shehan hashera Jun 11 '20 at 6:32
  • Could you explein what to do please.As I'm a new comer I don't understand what to do. – shehan hashera Jun 11 '20 at 6:34
  • I have edited answer step wise detailed. Hope you understand now. – Ajay Jun 11 '20 at 6:48
  • Thnx for your support. – shehan hashera Jun 11 '20 at 8:23
  • If it worked for you mark answer as correct. Whenever you find answer to your problem. mark/ upvote that answer helps others to get most suitable solution for their problem. – Ajay Jun 11 '20 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.