3

I use Ubuntu 18.04 bionic, and I use us(alt-intl) as a keyboard layout for Latin script, because sometimes I need type multilingual texts. Today I got very strange bug: now I cannot use the sign ' (apostrophe). When I press the key <AC11> assigned to apostrophe, I get nothing. When I press space key after that, I get space. When I press <AC11> + e.g. "a", I get "a", not "á". When I press SHIFT + <AC11>, I also get nothing. So, I can't type " (quotation mark) too.

The website keycode.info tells (pressing <AC11>): 222, event.key Dead, event.location 0 (General keys), event.which(deprecated) 222, event.code Quote

My /usr/share/X11/locale/en_US.UTF-8/Compose has such a rows (nothing abnormal):

# Spacing versions of dead accents
<dead_acute> <space>                    : "'"   apostrophe # APOSTROPHE
<dead_acute> <dead_acute>               : "´"   acute # ACUTE ACCENT
<Multi_key> <apostrophe> <apostrophe>   : "´"   acute # ACUTE ACCENT

In addition, when I use AltGr typing with us(alt-intl), it also doesn't work, but when I type Cyrillic texts with ru(udm), AltGr works normally.

Any advices, please.

2

<AC11> followed by A results in á for me with that layout.

Bug #1573755 comes to mind. For test purposes I suggest that you create an additional user, log in as that user, and find out if the issue is still present.

| improve this answer | |
  • Thanks Gunnar, the link you provided was very useful. I have solved my problem using 'ibus-setup' and 'im-config'. I don't fully understand what I did, but now all works. I suspect that the problem was concerned with concurrence between input methods. – udmnews Jun 10 at 21:49
  • @udmnews: Ah, good. Possibly you had XIM enabled and switched to IBus. Doing so proved to solve the problem for some users who have commented on that bug report. – Gunnar Hjalmarsson Jun 10 at 22:32
  • Thanks again. I've browsed a few old related topics here, e.g. this one [askubuntu.com/questions/88877/…. Traces of iBus are evident :-) – udmnews Jun 11 at 10:43
  • @udmnews: Nah, that question is about something else I think. But if you open the Language Support tool, you can easily see which "Keyboard input method system" you have selected. – Gunnar Hjalmarsson Jun 11 at 11:09
  • Yes, of course. But there was no need to check that parameter for many years :) – udmnews Jun 11 at 11:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.