0

I'm trying to install core18 with kernel 5.4. Everything boots fine, but when I get into the initial configuration screen and try to set up my networking, I am presented with this error:

Network configuration failed: 'ERROR: all-en: NetworkManager
        definitions do not support name globbing\n'         

What does this mean? How do I fix it? I am not passing any network configuration through hooks or anything, what's the deal?

0

This has been answered in the snapcraft forum: https://forum.snapcraft.io/t/core-18-networkmanager-definitions-do-not-support-name-globbbing/18125

| improve this answer | |
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Kulfy Jun 12 at 14:46
  • Hey look, 'dat me! I did find a half-solution that kinda works, but this was never formally or fully solved. I'd also love some explanation for why this happens and how this works. – Will Nilges Jun 12 at 15:54
0

For the sake of "completeness," I'll volunteer that did find that moving my configure hook from my kernel snap to a base-files snap (so that it executes later in boot, I guess?) does allow the networking to at least function, however, I still get the stray IP address every now and then.

The hook is confidential, but I am basically overwriting the netplan and then applying it in a hook.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.