I have a problem with my Canon PIXMA MP230.
The problem is that when I want to print a file, it goes to the print queue, but it does not print, printing appears stopped.
I clarify that I have the drivers installed but it still does not work.


enter image description here


I have had the same problem for a long time after upgrading to Ubuntu (Xubuntu/Ubuntu studio in my case) 20.04: my Pixma mp230 accepted print jobs, proudly announced "rendering complete" (in the log file) and just as proudly refused to print. I have tried to fix it a couple of times, but it failed miserably and was not a great priority these past few months.

This is the simple solution, which I found on distrowatch.com' s user rating page of Ubuntu 20.04 (the review dated 2020-08-19):

  1. remove ippusbxd (sudo apt remove ippusbxd in terminal)
  2. delete and reinstall the printer using the normal GUI printer utility
  3. Print a test page. Worked for me!

The proposed theory behind it is that ippusbxd "creates" a "ubuntu"-printer which interferes with the original printer/printer drivers (in the reviewer's case a Brothers printer, in my case a Canon Pixma mp230).

I am incredibly thankful to the original problemsolver for this simple solution and thought I would pay it forward here, where more people might see it.

You might also want to read these related questions where more knowledgeable people than me explain how all printers now are "network printers" or something like that. Apparently removing ippusbxd isn't the most elegant solution, but as long as it works I'm happy :-)

  • This answer seems totally appropriate here, as it's the same model printer. For other models, I'm not so sure it will work, so I would hesitate to post the same answer. At the moment, I'm not sure whether all these questions about being unable to print after upgrading to 20.04 should be closed as duplicates even though they are about different printer models. In general we prefer to link questions that are essentially the same and have the same answer rather than posting the same answer to all of them. If your answer works for all these questions, they should probably be closed.
    – Zanna
    Sep 18 '20 at 2:20
  • I fail to see how it would be inappropriate. People looking for a solution for this specific printer (including me) will end up on this page and until now didn't 't get an answer. As a bonus, the solution seems to work for several models, as described in my answer. I also documented where I got that answer.
    – rinre
    Sep 18 '20 at 5:42
  • I leave it to others to decide if all these seemingly similar questions should be merged, isn't the important thing that there is an answer or link to an answer after each question? 🤔
    – rinre
    Sep 18 '20 at 5:54
  • I would tend to agree with you on the whole, it's just that duplicate answers get automatically flagged and what tends to happen to them here is that they all get deleted except one, regardless of the situation with the questions. I don't support that as a rule, but I would like to figure out if these questions should be closed. I'll try to find some time to look into it.
    – Zanna
    Sep 18 '20 at 6:11

I had a similar problem with a Canon printer (Pixma IP7250), which worked fine with Ubuntu 18.04 and 19.10. But with kubuntu 20.04, it did not work at all. I finally found help in this forum, in the terminal I typed in

    sudo apt install cups-backend-bjnp

This installation worked quickly. After I could choose a driver which worked for my printer in the system settings, the printer worked properly with this driver!


This solution 'seemed' to partially work as I was able to find my MG2900 Canon listed in the GUI as a new, available printer, in Ubuntu 20.04, Mate desktop.

But...it still didn't print. So I unplugged it so as to reset the Wifi. The light was blinking. That stopped that, but still didn't print. So 'Delete'd it from the GUI with the intent of reinstalling it automatically again, like it had done a few seconds before. AND now, it doesn't show up in the listing of available printers attached to USB like it had the first go round.

I'd already installed sudo apt install cups-backend-bjnp

I'm going to reboot and see if that makes a difference.

Nope. Canon printer no longer shows up at all. Going to uninstall/reinstall in term now.


Solution provided above by lordparthurnaax

sudo apt install cups-backend-bjnp

worked for me like a charm with Ubuntu 20.10 groovy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.