0

This is a dual boot laptop, Windows 10 and Kubuntu 20.04 (see the end of the question for my system details). The problem I'm describing doesn't happen under Windows, but only under Kubuntu.

The laptop loudspeakers work fine. However, when I plug in the headphones, there is no sound coming through. If I left-click on the volume icon in the system tray, I see that, under 'Devices', it does say 'Headphones'. While still in this panel, if I switch to 'Speakers', the sound again comes out of the loudspeakers. If I switch back to 'Headphones', there is again no sound coming through.

Finally, once I leave the volume control panel, if I unplug the headphones, then sound starts to come out of the loudspeakers.

I've discovered that I can get the headphones to work by doing the following:

Plug in the headphones. Then:
right-click on the volume icon in the system tray -> Configure audio volume -> Audio -> Advanced

Under 'Built-in Audio', in 'Profile:', it shows 'Analog Stereo Duplex'. I select 'Off' (I get a brief splash-screen notification 'No output device'.) Then I immediately turn 'Analog Stereo Duplex' back on. And suddenly the headphones start working! (I also get another brief splash-screen notification, 'Built-in Audio Analog Stereo'.)

If I unplug the headphones, the sound starts coming out of the loudspeakers. If I plug them back in, there is again no sound: everything is back to how it was when I originally plugged them in. To get the headphones working again, I once again have to turn 'Analog Stereo Duplex' off and back on again.

Is there a way to fix this problem? I did quite a bit of googling, but couldn't find anything.

Here is my system configuration. The laptop model is Dell Latitude 7490.
Fast startup was disabled in Windows before installing Kubuntu, and it remains disabled.

Operating System: Kubuntu 20.04
KDE Plasma Version: 5.18.5
KDE Frameworks Version: 5.68.0
Qt Version: 5.12.8
Kernel Version: 5.4.0-33-generic
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-8650U CPU @ 1.90GHz
Memory: 15.5 GiB of RAM

The output of aplay -l is as follows:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3246 Analog [ALC3246 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0

* What solved the problem *

Following laugeo's suggestions, I first tried executing sudo alsactl restore. This had no discernable effect; in particular, the problem was not resolved. But then I tried laugeo's second suggestion: mv ~/.config/pulse ~/.config/pulseold, followed by killall pulseaudio. This seems to have solved the problem completely. The headphones work normally even after a reboot.

2
  • can you paste the result of this command ` aplay -l ` , also disable fastboot in windows can help – laugeo Jun 10 '20 at 13:28
  • @laugeo In WIndows, I have already disabled 'fast startup' before installing kubuntu. I don't know if that is the same thing as 'fastboot', but I suppose it is? I've appended the output of ` aplay -l ` to the end of my question. – linguisticturn Jun 10 '20 at 13:58
1

Various checks :

  • Try this command :

    sudo alsactl restore

  • Try to reset pulseaudio configuration with 2 commands:

    mv ~/.config/pulse ~/.config/pulseold
    killall pulseaudio

  • Run alsamixer (in a terminal) , is there a "headphones" fader ?
    It should unmute when inserting jack , or you can unmute manually pressing m key and increase volume with up/down arrow keys . (Move across faders using left/right arrow key)
    If headphones is ok after that, run

    sudo alsactl store

  • At last , if you have time, try to edit as root file /etc/modprobe.d/alsa-base.conf

    sudo gedit /etc/modprobe.d/alsa-base.conf

    and add this line with model option at the end:
    options snd-hda-intel model=dell-headset-multi
    save and reboot ,
    Remove this line if problem .
    If you have separate jack for headphone and mic,
    try one by one these models replacing "dell-headset-multi" :

options snd-hda-intel model=dell-headset-dock

options snd-hda-intel model=dell-headset3
options snd-hda-intel model=dell-headset4

1
  • The first suggestion had no effect, but the second one (killall pulseaudio) seems to have fixed the problem; headphones continue to work normally even after a reboot. Thank you!! – linguisticturn Jun 10 '20 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.