0

After I install Ubuntu on it, the cpus are always on high temperatures even with minimum cpu load. I even removed nvidia drivers to force use only intels, yet it is the same. At this time the load on each cpu is less than 10% from top cmd. But temp. are above 85 deg sensoroutput

Below is the output. After I reinstall the nvidia drivers

Fri Jun 12 13:35:08 2020       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 440.82       Driver Version: 440.82       CUDA Version: 10.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 105...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   72C    P5    N/A /  N/A |    318MiB /  4042MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      2000      G   /usr/lib/xorg/Xorg                           164MiB |
|    0      2176      G   /usr/bin/gnome-shell                          90MiB |
|    0      2531      G   ...AAAAAAAAAAAACAAAAAAAAAA= --shared-files    61MiB |
+-----------------------------------------------------------------------------+
7
  • Please do not add terminaloutput as picture, Just cp it from your terminal and paste it here.
    – nobody
    Jun 10, 2020 at 12:43
  • What's your CPU cooler. Is it stock, then definitely you need to upgrade it. Or I guess your CPU is thermal throttling, and It has nothing to do with ubuntu Jun 10, 2020 at 13:04
  • @AdupaVasista Well I have dual OS. So in Windows it is quite normal and gets hot only when I play games. But in ubuntu it is just all the time as I mentioned. As for CPU cooler yes it is stock. Jun 11, 2020 at 5:43
  • @nobody thanks for the suggestion. Will mind it from next time. Jun 11, 2020 at 5:44
  • Can you update your question by posting the output for nvidia-smi Jun 11, 2020 at 7:11

1 Answer 1

0

Under volting helps a lot when there is over heating (and by lot I mean A LOT). To be on a safer side, manufacturers supply higher voltage than required to the CPU (which causes heating), as at very lower voltages CPU doesn't work properly under stress. Under volting is completely safe. It will not void your warranty whatsoever. Under volting is basically removing the excess voltage supplied and giving the minimum voltage required to run the CPU smoothly.

Try intel-undervolt from here on GitHub.

Here is an article on CPU undervolting in Linux which I followed

Some terms in the guide might be deprecated. Refer to the first link for the deprecated terms.

Here is a step by step procedure with the non deprecated terms

  1. install git with sudo apt install git
  2. run git clone https://github.com/kitsunyan/intel-undervolt
  3. sudo su and then enter password
  4. run ./configure --enable-systemd --enable-openrc && make && make install
  5. close the root mode by typing exit and press enter
  6. run sudo systemctl daemon-reload
  7. run sudo gedit /etc/intel-undervolt.conf this will open a text editor
  8. change the value in line 10 (in front of CPU) to -130 like this undervolt 0 'CPU' -130 (recommended -125)
  9. now save that text file and exit
  10. run sudo intel-undervolt apply and then run sudo systemctl start intel-undervolt
  11. use the system for some time, if it looks stable then run sudo systemctl enable intel-undervolt.

As of selecting the offset, I use undervolt 0 'CPU' -130 in the /etc/intel-undervolt.conf file. As a beginner I would suggest you to stick to undervolting the CPU only.

To find the correct offset (unique to each CPU piece. Same CPU but on different computer could have different ideal offset) slowly lower the offset by small values (I used 10), and at the point where your PC crashes, is the threshold. And set the final value to threshold - 10. In my case it crashed at 140 so I set it to 130.

The only downside (if you don't choose sudo systemctl enable intel-undervolt) is that you will have to apply the settings on every boot. I have created an alias with alias us='sudo intel-undervolt apply && sudo tlp start'. So I just have to type us in the terminal on a boot, and then I am good to go.

Note: the crashing of PC to calculate the offset is completely safe. It will not damage you hardware whatsoever.

Note: Any Intel CPU can go to -125 at least, above that comes the difficult part. If you want to take it to the limit, then only try increasing it step by step. Otherwise -125 will work just fine for any Intel CPU.

You could try to switch from NVIDIA card to integrated graphics card.

Run sudo apt-get install nvidia-prime. This is a software to control which graphics card to use. Reboot your PC now.

Run sudo prime-select intel, this will switch to integrated graphics card, which will lower the temps a lot. Reboot again and we are done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.