8

I am using Opera 68.0.3618.125 on latest Ubuntu version. But I can't watch videos. For example on Twitter. Everyone says get libffmpeg.so and copy to /snap/opera/current/usr/lib/x86_64-linux-gnu/opera but I can't access this file even I'm in root access. Please help me.

2

7 Answers 7

5

Install ffmpeg, which will install the missing shared library libffmpeg.so:

sudo apt install ffmpeg

Sorry for this late answer, I had only just realised my suggestion which I was not 100% certain about worked for you. But here it is.

0
4

In my case ffmpeg didn't worked. I simply search for any possible libffmpeg.so in my system and found some varieties and pick one among them.

I selected from skype directory, and copied to opera directory and voila!! it worked!

Below are the steps.

  • Update files DB, so it search files better.

    $ sudo updatedb
    
  • Serach for libffmpeg.so file.

    $ locate libffmpeg.so
    /home/ravi/sw/Postman/app/libffmpeg.so
    /snap/flock-chat/281/libffmpeg.so
    /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so <-- This was already there. I just replaced it with skype's libffmpeg.so
    /usr/share/code/libffmpeg.so
    /usr/share/skypeforlinux/libffmpeg.so
    
  • Backup existing libffmpeg.so, just in-case things go wrong we can revert this file.

    $ sudo cp /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so.bkp
    
  • Overwrite libffmpeg.so

    $ sudo cp /usr/share/skypeforlinux/libffmpeg.so /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so
    
3

All problems with streams and Opera comes from .deb installation pack. We all have got .deb from the official Opera download page.

But official Opera has some problems with licences and official .deb Opera cant use latest codecs for playing streams.

Stream works only on snap opera, not .deb

If you have Ubuntu 20.04 u can just use this command

sudo snap install opera

Enjoy.

2
  • Thanks a lot! I was struggled with this issue from years. Installing opera from snap is much faster and clear than chromium codecs and making symlink to libffmpeg
    – Dibo
    Commented Sep 2, 2022 at 19:13
  • Does it use the same preferences, cache, open tabs etc. files? Are there any downsides for using the Snap version? Commented May 9 at 8:57
2

i had the same problem, just installing ffmpeg didnt work, so my solution is to copy the up to date chromium library to the opera directory. I called it fixopera.sh:

#!/bin/sh
apt-get -y update && apt-get -y install chromium && mv /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so.old && cp /usr/lib/chromium/libffmpeg.so /usr/lib/x86_64-linux-gnu/opera/

copied it in /etc/cron.daily/, to make it a root cron job and executable with chmod +x. so in case anything goes wrong you have a backup of your old file named libffmpeg.so.old

2
  • Clever! :) a few questions: are you using 20.04? Did you install with snap, or apt, or any other? Thanks. Commented Feb 13, 2021 at 8:36
  • Linux Mint 20.04 (so: yes). I used the officially recommended deb package from opera website, which i think also sets an apt key so opera will be updated along with the other apps on apt-get update && apt-get dist-upgrade. Btw maybe setting a cron job on /etc/cron.daily/ is not the best way, maybe just add the script in your root crontab with sudo crontab -e.
    – moe
    Commented Feb 16, 2021 at 11:04
1

Instead of replacing the existing libffmpeg.so (which might be undone by an update) I would suggest to create sub-directory lib_extra in the opera main directory and copy or symlink the new libffmpeg.so to this directory, e.g. (as root)

cd /usr/lib/x86_64-linux-gnu/opera
mkdir lib_extra
cd lib_extra
ln -s /path_to_other/libffmpeg.so .

Edit 2024-02-24: This solution does not work anymore, at least not on my Debian 12 with Opera 107.0.5045.36. Here I have to replace the file libffmpeg.so in the Opera directory by another file (either link or copy) as mentioned in the posts above.

0

Similar to the other answers, except using a symlink instead of copying the library, is this solution from the Opera forums, Solving the problem of the Opera browser with video playback in Ubuntu and similar distributions (Linux Mint, KDE neon):

First of all, you need to install the chromium-codecs-ffmpeg-extra package. You can do this using the terminal with the following command:

sudo apt install chromium-codecs-ffmpeg-extra

Usually the second step is to create a symlink for the file libffmpeg.so, but since now the Opera browser delivers a file with this name (but not solving the problem), we will delete it and then create a simlink to the new file. File deletion:

sudo rm /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so

Creating a simlink:

sudo ln -s /usr/lib/chromium-browser/libffmpeg.so /usr/lib/x86_64-linux-gnu/opera/

-1

Yes, it's all about the libffmpeg.so file. I had to download it from a previous version of Ubuntu as explained in this post The Videos Don't Play Topic as none of the files in 20.04 worked.

I did some research and replaced libffmpeg.so with the one I downloaded from https://packages.ubuntu.com/xenial-updates/amd64/chromium-codecs-ffmpeg-extra/download

Find and extract libffmpeg.so in the downloaded package, then save it as libffmpeg.so in /usr/lib/x86_64-linux-gnu/opera (the path may vary), replacing the existing file if it is there. You will need to do this with root privileges.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .