1

I "inherited" a Dell Inspiron 5567 from my college age daughter. Some system specs: Memory-7.7 GB, Processor - Intel® Core™ i5-7200U CPU @ 2.50GHz × 4 , Graphics - Mesa Intel® HD Graphics 620 (KBL GT2), Disk Capacity - 1 TB.

The machine was essentially a brick when I got it, so I decided to replace Windows completely with Ubuntu 20.04. I made a bootable USB with rufus. That works fine. Things seem to work well during the "tryout" once booted, so I installed from the USB drive. UEFI is enabled and Secure Boot is on.

Unfortunately, the machine does not boot once the USB is removed. The installed boot file is shimx64.efi. I also tried booting with grubx64.efi, mmx64.efi and bootx64.efi. No joy whatsoever. mmx and grubx give the error, "Operating System Loader Signature not found in Secure Boot Database" with Shutdown as the only option.

I found some threads that seemed similar to this but those suggestions did not work.

Any ideas?

Thank you, Tom Zeller

3
  • Disable Secure Boot – Ray Wu Jun 9 '20 at 15:35
  • Well, that was hard enough. For the record, the combo that worked for me was disabling Secure Boot and booting with grubx64.efi. – tzellerubuntu Jun 10 '20 at 11:15
  • Thanks, Ray Wu! – tzellerubuntu Jun 10 '20 at 11:15
0

You should try disabling Secure Boot, and for Ubuntu, the right file to boot is grubx64.efi.

Secure Boot is put in place by OEMs to prevent unsigned drivers and EFI shells from being used.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.