0

I'm having the same issue and I'm not able to find any solution just like:

deja-dup-backup-tool-error

backup-failed-deja-dup

deja-dup-backup-fails

Installed versions:

  • Duplicity 0.7.17

  • Python 2.7.17

  • deja-dup 37.0

I have configured deja-dup to:

  • daily backup folder ~/Documents (du -sh 86GB)
  • to the backup server accessible over LAN or OpenVPN
  • with more than 7TB free space
  • using sftp connection

It worked like a charm 4 years without any changes. It stopped working after apt upgrade most probably 6.4.2020 (dd.mm.yyyy) - last backup date is 6.4.2020

Now, it trys to do "clean backup", but with the well known result. The Traceback looks quite simmilar, it looks that it fails in the incremental (just like here backup-failed-deja-dup) and even clean backup because of the same reason.

Traceback (innermost last):
  File "/usr/bin/duplicity", line 1555, in <module>
    with_tempdir(main)
  File "/usr/bin/duplicity", line 1541, in with_tempdir
    fn()
  File "/usr/bin/duplicity", line 1393, in main
    do_backup(action)
  File "/usr/bin/duplicity", line 1414, in do_backup
    sync_archive()
  File "/usr/bin/duplicity", line 1204, in sync_archive
    copy_to_local(fn)
  File "/usr/bin/duplicity", line 1146, in copy_to_local
    fileobj = globals.backend.get_fileobj_read(fn)
  File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line 676, in get_fileobj_read
    self.get(filename, tdp)
  File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line 395, in inner_retry
    % (n, e.__class__.__name__, util.uexc(e)))
  File "/usr/lib/python2.7/dist-packages/duplicity/util.py", line 79, in uexc
    return ufn(unicode(e).encode('utf-8'))
 UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 19: ordinal not in range(128)

I just try sudo apt install --reinstall duplicity deja-dup python-minimal

What could I try next? Any ideas?

Please if there is anyone with the same problem, similar TraceBack, and have any other information which is not provided in this description, and even anyone without reputation points, feel free and edit this post to avoid unnecessary fragmentation. It would be nice to make all related information at one place, including links to the other asked questions or related informations somewhere on the net.

5
  • Last worked "6.4.2020"? 6 April 2020? (most of the world uses dd-mm-yy, though mm-dd-yy, yy-mm-dd and other formats are also used so better if you're specific)
    – guiverc
    Jun 9, 2020 at 8:39
  • what is you duplicity version? if it is 0.8.x try upgrading python to python3. there were lt's of changes. Jun 9, 2020 at 17:51
  • THX for notice about the date format, I added mask to the description. ;) I have installed: Duplicity 0.7.17 Python 2.7.17
    – Ruprecht
    Jun 10, 2020 at 9:31
  • Now I noticed, that I have installed python 2.7 and also python 3.6, but Python 2.7 is used by default. I find out that duplicity 0.7.17 can not work with python3 because of The statvfs module has been removed., and there would by more causes probably. Therefore I am trying figure it out with the python 2.7 whenever i have some free time.
    – Ruprecht
    Jun 12, 2020 at 8:15
  • There is similar bug (and some linked to it) which should be resolved, but maybe this is caused by something else: [bugs.launchpad.net/duplicity/+bug/1386373] Thanks for every advice or idea.
    – Ruprecht
    Jun 12, 2020 at 13:13

1 Answer 1

0

This worked for me: Re-check and repair owner and rights of the backup folder.

context: I tryed and move the "old" backup folder, and create new one for fresh backup more than month ago. New backup works like a charm, But today exactly the same error appeared again! But today I know, that I did some changes on the server, and there was misconfigured owner of the backup folder. Whenever I "chowned" the folder, backup is working again.

I moved back the "old" backup folder which did not work and was not used for about 6 months, and re-set the owner / rights. The backup is working again and full backup is creating just right now.

I think, that this should be fixed: Backup could check the rights (or maybe better, it could catch exeptions) of the backup folder, including subfolders and files, and return valid error response in any cases.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.