3

Mouse left-click didn't work in Setup at all, so I had to run Try mode to install 20.04. Oddly the mouse click worked in Try mode but not in normal setup.

Once 20.04 was installed, left-click became intermittent. If I alt-tab between windows, clicking will work temporarily but then if I try to click on some other window it won't work. I've read things about invisible windows interfering? This happened on a completely clean install (even in setup!) before I installed anything. There are a TON of posts about this same problem in various forums and I have tried every solution, none of them work.

The only thing that makes the mouse work temporarily is "sudo service gdm restart" but A) that only works until the next reboot, and B) that makes the forward & back mouse buttons stop working which is maddening.

This happens with several brands/models of mouse, on various USB ports, using 2 different USB controllers (chipset and ASMedia).

Asus Rampage VI Extreme X299 with GeForce GTX 1660 and Samsung NVMe. No other devices/cards. This is a desktop so there is no touchpad and I do not have multiple pointing devices. I have also tried a different keyboard.

[EDIT] I ran setup on a completely different system, an MSI Intel Z370, and the mouse left-click is broken. Is Ubuntu 20.04 mouse support completely borked?

5

Have you tried this link? https://unix.stackexchange.com/questions/369097/mouse-left-click-stops-working. Just to summarize, try switching to tty1 (by doing Alt + Ctrl + F1) then switching back to normal by doing Alt + Ctrl + F7. IF that does not work, try:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

I hope this helps.

3
  • 1
    Neither of those worked for me unfortunately. – Abe Petrillo Sep 30 '20 at 18:15
  • It worked...but now the tracking speed is painful and I still can't scroll – TheTechRobo36414519 Nov 15 '20 at 16:59
  • Alt + Ctrl + F1 took me to switch user, I just logged back in. The mouse was still frozen but pressing Ctrl+Alt+T (to open the terminal) un-froze it. Thanks! – gekepdp Feb 5 at 11:55
1
  1. go to gnome tweaks
  2. select- kybord and mouse
  3. on the mouse click emulation ... by default 'fingers' option will be selected change it to 'Area' That's all

credit: https://youtu.be/GaZefnkB04o

0

I had this too. Tried all these things, none of them worked. This fixed it:

sudo apt install -reinstall ubuntu-gnome-desktop
2
  • 1
    But it seems that your solution will reinstall the desktop rather than fixing the problem. – user833907 Nov 18 '20 at 15:28
  • 1
    It worked for me, don't care what was the problem, the thing is: This solved the problem. Congrats. – Carlos Barcellos Jan 11 at 13:22
0

Left click usually dies after wakeup from sleep.

This did the trick for me:

sudo udevadm trigger

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.