0

this is my first time asking a question here and if anyone could help me solve it, I will be very grateful (I am quite beginner). I have Ubuntu 18.04 in my HP Pavilion Laptop 15-cw0002la with AMD Ryzen 5 processor. When I press the power off button or even in the terminal typping "sudo shutdown -r now", my laptop's screen is off, but the light is still on and it keeps running, then I need to press the power button for 5 seconds to turn the laptop off.

I have tried everything in the following web pages and still doesn't work. Ubuntu 18.04 stuck at shutdown https://unixmen.com/fix-shutdown-power-computer-ubuntu-14-04/

Specially changing

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

and to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapic"

  • Show me sudo dmidecode -s bios-version. Start comments to me with @heynnema or I'll miss them. – heynnema Jun 6 at 21:44
  • @heynnema, it says ´F.35´ – David xie li Jun 6 at 22:11
  • Are you using Ubuntu? Which release? – Pilot6 Jun 8 at 17:09
  • @Pilot6 I forgot to tell, I ended up installing Debian 10, sorry, I am very new at this – David xie li Jun 8 at 17:21
  • So, this question is now off-topic at this site. Changing distros rarely helps to solve hardware problems. – Pilot6 Jun 8 at 17:22
0

HP Pavilion Laptop 15-cw0002la

You have BIOS F.35.

There's a newer BIOS available, F.42, dated Dec 11, 2019, and can be downloaded here.

Note: Confirm that I've got the correct web page for your model #.

Note: Have good backups before updating the BIOS.

| improve this answer | |
  • I have already installed the new BIOS on the windows dual boot side, but now when I enter to Ubuntu still can't power off, but now there is also no wifi or sound. Help :( – David xie li Jun 7 at 21:56
  • @Davidxieli Did you undo the changes that you made /etc/default/grub and then sudo update-grub? Did you reset the BIOS and then check individual BIOS settings to assure that they're correct? – heynnema Jun 8 at 0:16
  • I am going to ask it in a question apart, thanks a lot – David xie li Jun 8 at 15:41
  • @Davidxieli Why not finish this question? Check the settings in my prior comment first. – heynnema Jun 8 at 15:45
  • already checked, all good, the only problem left is that it doesn't detect the wifi, only ethernet works – David xie li Jun 8 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.