0

I run Ubuntu server 20.04 (before I tried it with 18.04). I have everything freshly installed and updated. Then I tried to run a specific program but I got

libboost_system.so.1.58.0: cannot open shared object file: No such file or directory

I also tried to install the newest libboost_system1.67.0, however this didn't help.

Is it really that I need to recompile the software to include the newest libraries or is there some workaround?

0

You have installed a software that is not supported by Ubuntu. Obviously the software (which you did not mention) needs some older libraries. So you've got those possible solutions:

  • Recompile and link the software with the current libraries.
  • Try to find a snap package that includes all the dependencies
  • Find a version that is compatible with Ubuntu 20.04 - e.g in a ppa

What you shouldn't do: Do not try to install the needed libboost_system 1.58.0 (which your software needs),as it may break you system. And it probably wont work, since its dependencies are also missing.

5
  • Hi, Thanks for your answer. Sorry - I just didnt think it would matter, it is an old qt-wallet from the shield coin (abandoned coin, so never updated anymore). Im trying to recompile it now - forgive me this question - but if I recompile it, does it link to the newest library automatically? Best N – Nuschnusch Jun 6 '20 at 22:51
  • Yes it should. If you are content with my answer, I'd appreciate if you'd accept it. Please keep in mind that you'll need all the dependent header files for compiling... – kanehekili Jun 6 '20 at 22:52
  • Thanks for your help, Im trying it now - but Im getting alot of errors :D Maybe it will work either way :) – Nuschnusch Jun 6 '20 at 22:58
  • You'll need quite a bunch of Qt libraries to compile. If you succeed you should share you're result in a ppa . It may help others... I wish you success. – kanehekili Jun 6 '20 at 23:18
  • Thanks, it worked :) – Nuschnusch Jun 7 '20 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.