2

I've upgraded to Ubuntu Desktop 20.04. (sudo do-release-upgrade after regular sudo apt update and sudo apt upgrade)

Several things in the appearance now seem off. The terminal previously had a maroon background colour, now it's plain white. The terminal scroll bar on the right is badly positioned. See screenshot here.

The icons used don't appear as expected. I'm expecting something like this. Instead I see this. Look at the icons on the left here.

The Language Support icon also appears as a white silhouette.

Changing theme variant under Settings > Appearance to "dark" has no effect.

Something in gnome needs resetting?

More info:

I just installed Gnome Tweaks, "Applications" was originally set to Adwaita. See here. Screenshot doesn't enable capture of picklist options, but the options are Adwaita (default), Ambience, HighContract, HighContrastInverse, Radience. The icons seem to be messed up; For example, there's no difference between HiColor, DMZ-White, DMZ-Black.

Options for Icons are Adwaita (default), DMZ-Black, DMZ-White, Gnome, HiColor, HighContrast, Humanity, Humanity-Dark, LoginIcons, Ubuntu-mono-dark, Ubuntu-mono-light.

The default "Yaru" theme for 20.04 is not listed, but is present under /usr/share/themes/

Resetting to defaults causes all Appearance "Themes" options to go blank.

XDG_SESSION_DESKTOP:

$ echo $XDG_SESSION_DESKTOP
ubuntu
4
  • Was it Ubuntu? It looks more like Xubuntu. – Pilot6 Jun 6 '20 at 16:52
  • 2
    @Pilot6 How so? It pretty much looks like Ubuntu (with GNOME 3) with the Adwaita theme to me. – pomsky Jun 6 '20 at 16:54
  • 3
    What icon and application themes do you currently have? Check in GNOME Tweaks. Can you change those to any other that fixes the issue for you? Also what is the output of the following command in Terminal: echo $XDG_SESSION_DESKTOP. Please edit your question and clarify. – pomsky Jun 6 '20 at 16:57
  • Question updated with more info. – powlo Jun 6 '20 at 17:37
2

Follow the instructions here:

sudo apt-get --reinstall install ubuntu-session
sudo apt-get --reinstall install yaru-*
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.