7

Got proprietary Nvidia drivers installed by Ubuntu itself, graphic card is recognized well by the system yet brightness control does not work when adjusted by either FN + F5/6 shortcut or by dragging brightness slider manually (keyboard shortcut triggers slider move as well, so it's heard by the system).

However: xrandr | grep " connected" | cut -f1 -d " " produces single output DP-2 and xrandr --output DP-2 --brightness 0.7 does change the brightness.

Googled a lot, tried various options, neither works to me. What can I do to make it work when dragging the slider as well?

5
  • Do you by any chance have acpi=off or noacpi in your grub boot parameters, which would have the effect of disabling your FN+function key controls?
    – Enterprise
    Jun 6 '20 at 16:34
  • Nope. Config is good and all the FNs are working.
    – Zazeil
    Jun 6 '20 at 16:34
  • What does ls /sys/class/backlight reveal? On a laptop the hardware brightness is what FN keys control. Using xrandr is software control primarily used for external monitors not built in laptop displays. Jun 6 '20 at 16:52
  • @WinEunuuchs2Unix acpi_video0. What does that mean?
    – Zazeil
    Jun 6 '20 at 16:58
  • @SerejaBogolubov See if this helps: nvidia backlight brightness problem Jun 6 '20 at 17:11
7

So, finally - after trying lots and lots of options - following helped me: At the /usr/share/X11/xorg.conf.d folder find file related to your nvidia and append following section:

Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "<your graphic card as it named in your system>"
    Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

You can find the name of your graphic by searching for "system" in your Ubuntu. In my case it is GeForce GTX 1660 Ti so in abovementioned configuration file it gonna be BoardName "GeForce GTX 1660 Ti" - enclosed in doublequotes.

Save and reboot.

6
  • Thank you! That one worked for me. Btw it worked both with and without the BoardName line for me. Nov 14 '20 at 3:36
  • Very helpful, thanks a lot :)
    – Alen
    May 18 '21 at 20:21
  • @Sereja Bogolubov: IS this a Laptop or Desktop?
    – stephanmg
    May 30 '21 at 18:59
  • 1
    @stephanmg laptop
    – Zazeil
    May 30 '21 at 19:42
  • I see, for regular monitors one can use the OSD panel of the monitor.
    – stephanmg
    May 31 '21 at 7:03
1
  1. Run nvidia-settings

  2. Select X Server Display Configuration

  3. Click Save to X Configuration File (don't click Save on opened dialog)

  4. Click Show preview...

  5. Copy Section "Device" ... EndSection (maybe you will need to copy Monitor and Screen sections)

  6. Create file /usr/share/X11/xorg.conf.d/10-nvidia-settings.conf and paste copied text in it, add to Device section Option "RegistryDwords" "EnableBrightnessControl=1", save file

  7. Add to file /etc/initramfs-tools/modules

    nvidia
    nvidia-drm
    nvidia-modeset
    
  8. Run sudo update-initramfs -u

  9. Restart

If you played with file /etc/default/grub than try to remove all acpi... settings from GRUB_CMDLINE_LINUX_DEFAULT=

Description about steps 7 and 8 is here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.