0

I bought a laptop Lenovo IdeaPad S145 which came pre-installed with Windows 10. Then I prepared an Ubuntu 18.04.4 LTS bootable usb drive and installed Ubuntu alongside Windows 10. To make it happen I had to modify "Boot mode" to "Legacy support". Now if I have to boot Windows then "Boot mode" should be "UEFI" and for Ubuntu "Legacy mode". I tried fixing it using boot-repair but boot repair already shows "separate /boot/efi/ partition" and selected the efi partition present on SSD. I have created summary using boot-repair http://paste.ubuntu.com/p/hp7nGk3xjQ/ Please suggest me how can I enable a dual boot in grub menu.

9
  • 3
    Reinstall Ubuntu in UEFI mode. – user68186 Jun 5 '20 at 23:23
  • Go into BIOS and change to UEFI mode not Legacy. Also disable Secure Boot. Win10 is installed on an M.2 GPT formatted disk which must boot in UEFI mode. Boot to Live Ubuntu, remove partition nvme0n1p5 using Gparted, try another boot-repair then reboot. – Paul Benson Jun 6 '20 at 0:15
  • @PaulBenson, This article (as well as my experience) actually states that Ubuntu supports secure boot completely – kesarling He-Him Jun 7 '20 at 18:43
  • Did you try using the .exe installer which comes in the ISO file? – kesarling He-Him Jun 7 '20 at 18:45
  • @d4rk4ng31 I'm well aware Ubuntu supports Secure Boot. The problem is when you're trying to set up a dual boot with Win10 while SB is enabled, once completed with some machines they boot straight into Win10. That happened to me in the beginning. – Paul Benson Jun 7 '20 at 19:51
1

I have had this problem with certain laptops. My usual solution is.

Set boot mode to UEFI. Plug in the Ubuntu install/live usb drive. Don't boot, go into boot order menu. There should be an entry for OEM manufacturer install or something similarly named. Go into that and follow installation instructions.Take care of the extra partitions u need to create here, from the usual Ubuntu install.

This solution has usually worked for me and is a quick fix.(Do explore other options if you have the time)

hope it helps you today.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.