0

I have a Spectre with a touchscreen which inevitably registers phantom touches after running for a while. I've searched this forum and found several "Disable Touchscreen" entries, but none seem to work on my machine.

When I try xinput disable {touch screen id} I get WARNING: running xinput against an Xwayland server. See the xinput man page for details.

I've also tried the method of editing /usr/share/X11/xorg.conf.d/10-evdev.conf to add Option "Ignore" "on" or MatchIsTouchscreen "off" and those don't seem to work either.

Does anyone have any other ideas? Thanks.

4
  • Welcome to Ask Ubuntu jeffedsell! I think the clue is in the warning: the solutions you've found were for machines with Xorg, and it looks like they don't work the same way with Xwayland. Quoting from the question at unix.stackexchange.com/q/569265/275183, "disabling an Xwayland device with xinput does not disable the device in Wayland-native applications". So your question is really "what's the equivalent of xinput --disable for Wayland?". Also, it might be helpful if you add some more details about your system.
    – Ratler
    Jun 7 '20 at 21:41
  • Using evtest --grab (see forum.manjaro.org/t/disable-keyboard-in-gnome-wayland/94661 for details) sounds promising, though a bit hacky. I'd submit as an answer, but I'm running Xorg, so I can't confirm it would work for you. Experiment, and if it's successful, please submit as an answer.
    – Ratler
    Jun 7 '20 at 22:13
  • Well, thanks. I tried it and it does work -- presumably I could run this command at startup, but I see why it's hacky. I'm browsing the Ubuntu wiki regarding Wayland, but it's very much over my head.
    – jeffedsell
    Jun 8 '20 at 18:20
  • !Machine specs
    – jeffedsell
    Jun 8 '20 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.