2

I am having troubles with getting Nvidia GeForce RTX 2070 drivers going on my AMD Ryzen desktop. I have entered the following terminal commands:

  • ubuntu-drivers devices
  • sudo ubuntu-drivers autoinstall

Terminal screen

As can be seen, everything seems to install correctly but when I then reboot it goes to a logon screen with my name as the account name. When I try and login by entering a password, nothing happens. It just stays on the login screen. The only way to fix it, is to revert back to the nouveau driver by going to the command terminal as root (ctrl+alt+F2) and entering the following:

  • sudo apt-get remove --purge nvidia-*
  • sudo dpkg-reconfigure xserver-xorg

I know lots of posts have been made about this (but for 18.04, 16.04, 14.04 and 12.04) and the following command has been suggested:

  • sudo prime-select nvidia

And then followed by these commands:

  • sudo add-apt-repository ppa:bumblebee/stable
  • sudo apt-get update
  • sudo apt-get install bumblebee bumblebee-nvidia

However, is this really the proper way to resolve this issue, and will it work? (or what is bumblebee?)

Thanks

  • 1
    please don't post screenshots of your terminal - you can edit your question to copy/paste the text from your terminal. – guntbert Jun 7 at 19:14
8

So I had a total disaster with "Bumblebee". I entered the above commands but they caused all sorts of weird responses resulting in me having to give up and just re-install a clean copy of ubuntu 20.04 (not the reinstall option but the replace install option).

So how did I fix it? Well I didn't use bumblebee and instead did this:

  1. From terminal I entered sudo ubuntu-drivers autoinstall
  2. When I restarted, I got the login problem. So selected ctrl+alt+F4
  3. Entered sudo apt-get purge nvidia*
  4. Then sudo apt-get install nvidia-driver-440
  5. Then sudo apt-get install sddm
  6. Then sudo dpkg-reconfigure sddm (I got an option for choosing gdm3 or sddm, I chose sddm)
  7. Finally reboot

This gave me a different login screen, BUT I could actually login and the nvidia driver was running (and its control panel properly activated).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.