7

Computer worked fine for a couple of weeks.

Hardware specs:

  • CPU: AMD Ryzen 9 3900X 12core
  • Memory: 64GB Corsair
  • GPU: Sapphire Radeon RX 5500 XT NITRO+ 8GB
  • Motherboard: ASUS ROG Strix X570-F GAMING
  • Wireless keyboard and mouse
  • monitor: 4K 60Hz

Problem: Computer freezes. It freeze most frequently when watching video in browser, after a while sound stops, a few seconds later computer is in this state:

  • I can move the mouse-cursor, but clicking does nothing.
  • Ctrl + Alt + F1 does nothing
  • Short pressing the power button does nothing
  • Picture is frozen except for the mouse cursor moving
  • Same problem when connecting another keyboard and mouse
  • SysRq REISUB works

Debugging different resolutions:

  • No Problems: Resolution 1920 x 1080, Refresh rate: 60Hz Scale: 100%
  • Fails: Resolution 3840 x 2160, Refresh rate: 60Hz Scale: 100%
  • Fails: Resolution 3840 x 2160, Refresh rate: 60Hz Scale: 125%
  • Fails: Resolution 3840 x 2160, Refresh rate: 60Hz Scale: 150%
  • Fails: Resolution 3200 x 1800, Refresh rate: 60Hz Scale: 100%
  • Fails: Resolution 2560 x 1440, Refresh rate: 60Hz Scale: 100%

Debugging:

  • htop: CPU is below 10%
  • watch sensors: CPU heat is around 50C, CPU power consumption is about 5-10W
  • tail -f /var/log/{messages,kernel,dmesg,syslog}: didn't give any messages that looked interesting, last error before crashing was some DNS stuff.

Does anyone have a suggestion how to debug this problem?

5
  • You mention SysRq REISUB does nothing, which makes me think you didn't use the ALT key, or it was disabled (as it'll cause reboot unless kernel is frozen, however the mouse cannot move if kernel is dead!! so something doesn't add up!? at least to me [unless keyboard was disconnected or something you've not mentioned]). – guiverc Jun 5 '20 at 12:09
  • Thanks, I did SysRQ REISUB the wrong way, I'll try again next time computer freeze. I've updated the question – andrsv Jun 5 '20 at 12:16
  • It was happening to me every time I opened the menu to show all the apps, but it was fixed in recent updates, so you should check if your hardware is ok. – Lucas Java Jun 11 '20 at 8:09
  • I have pretty similar hardware and I'm getting the error messages described here gitlab.freedesktop.org/drm/amd/-/issues/892 No amount of kernel/driver/mesa updates has managed to solve the issue for me so far. – Bozhidar Batsov Sep 5 '20 at 6:30
  • @BozhidarBatsov thanks for your input, it doesn't seem to be the same problem. The only similarity I find is the hardware. As far as I understand, my computer and your computer got different issues. Or am I wrong? Also I couldn't find your name on the page you are referring to. – andrsv Sep 29 '20 at 7:20
2

In /etc/profile, I would add this: setxkbmap -option terminate:ctrl_alt_bksp

Then, logout and login.

The next time you freeze, you can try entering Ctrl-Alt-Backspace to restart the desktop instead of having to reboot. In addition to getting you back to business faster, it tells you that X is still alive during a freeze. Not sure why "ctrl + alt + F1 does nothing".

A similar situation is also a current challenge for me on a Raspberry Pi 4 8GB with the Xubuntu desktop.

Good luck with a resolution.

1
  • Thanks, I'll try it out. I've added it now. I've decreased screen resolution, and didnt get any problems with lower screen resolution. I increased to 4K and it froze after a few hours. Now I am back to lower screen resolution. I'll do some tests regarding graphics card when I get time for it :) – andrsv Jun 24 '20 at 6:58
2

Running xset s off in a terminal window before it freezes seems to help.

When the error occurred, I recognized a lot of messages like beneath in /var/log/Xorg.0.log

(II) event4  - Video Bus: device removed
(II) event1  - Power Button: device removed
(II) event9  - Keyboard: device removed
(II) event5  - Mouse: device removed
3
  • Thanks, I've upgraded drivers for graphic card and updated Kernel. It doesn't seem to crash as frequently as it did. I'll follow Xorg log and see if something happens there before next time it freeze. I see that "xset s off" is related to screensaver. I don't see why this is relevant as it freeze while I am working. But I'll try it. – andrsv Jul 17 '20 at 10:08
  • @andrsv have you solved this issue? suddenly since today it happened to my computer, I haven't updated anything since 26 days, and it works normally until yesterday (just need to wait 10-30 secs to unfreeze), but since today this happened to me too.. askubuntu.com/questions/1287502/… – Kokizzu Oct 27 '20 at 19:43
  • @Kokizzu, we definitely don't have the same problem. I can not go to any terminal window and type anything, as the OS is not responding to mouse clicks or keyboard. It only responds to mouse movement. Also there is no clear reason why things crash in my situation. I haven't had the problem since I upgraded to Ubuntu 20.10. But I haven't tested enough to give a conclusion yet. – andrsv Dec 21 '20 at 7:29
1

My computer haven't frozen since I upgraded to Ubuntu 20.10

2
  • Just want to confirm your issue remained resolved with 20.10? I'm trying to drive dual 4K monitors with the same symptoms. Dropping back to dual 2K monitors seems to be the only solution available to me at the moment. This is on both 20.04.2 LTS and 21.04. – Moth Jun 3 at 0:24
  • I haven't had the problem for a long time. But I'm mostly using 2K monitors due to corona and home office. – andrsv Jun 4 at 11:55
0

I had similar problem. I solved it by removing nvidias closed driver. Some one suggested at another forum that rolling back nvidia's driver little bit could also help.

2
  • 1
    Can you provide details on how to do this? – Nmath Feb 20 at 21:13
  • Sapphire Radeon RX 5500 XT NITRO+ 8GB doesn't support NVIDIA drivers – andrsv Mar 1 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.