2

I tried to install repo , but apt said that package is not available. I refreshed package lists cache by apt update , but the same message.

So, I opened my browser and searched Ubuntu repositories for "repo" by going to the URL https://packages.ubuntu.com/repo. I saw that a repo package is available for xenial, bionic, eoan and even the upcoming groovy release. But it is not available for my Ubuntu, 20.04 Focal Fossa.

Why isn't it available? How can I install it?

  • 3
    It isn't available in Ubuntu 20.04 because it's developers were slow to transition from Python2 (which will reach EOL in late 2020) to Python3. – user535733 Jun 5 at 11:46
2

I didn't want to add eoan to my /etc/apt/sources.list file permanently so I downloaded the packages manually:

I then installed them using sudo dpkg -i <filename>, python-kerberos first.

| improve this answer | |
1

I have managed to install repo by downloading and installing repo and it dependency python-kerberos from eoan repositories from https://packages.ubuntu.com. To install, type these commands and hit enter:

apt update
apt install gnupg python

This to ensure that all dependencies are installed. Now download repo and it's dependency python-kerberos as described above.

| improve this answer | |
1

I encountered this issue as well and I solved it by manually installing repo from the repo installation page:

Taken from the install instructions:

mkdir -p ~/.bin
PATH="${HOME}/.bin:${PATH}"
curl https://storage.googleapis.com/git-repo-downloads/repo > ~/.bin/repo
chmod a+rx ~/.bin/repo
| improve this answer | |
  • 1
    Don't forget to add ~/.bin/ to your path. – Jacob Sundqvist Sep 21 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.