4

I decided to swap from Windows to Ubuntu 20.04 (I'm a newbie) and I found a problem with the touchpad.

uname -r gives: 5.4.0-33-generic

xinput gives:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Logitech Wheel Mouse                 id=15   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Lenovo EasyCamera: Lenovo EasyC           id=12   [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]

It shows the touchpad as PS/2 Logitech Wheel Mouse.

xserver-xorg is already the newest version (1:7.7+19ubuntu14).

What I've tried:

I installed first the binary:

xserver-xorg-input-synaptics_1.9.1-1ubuntu1_amd64.deb

No problems, but the touchpad still not working.

I'd appreciate help to fix this issue; I know that it is known issue, and probably the solution is in front of me, but you can appreciate I'm new to Ubuntu.

7
  • First of all there is no need to install any version of xserver-xorg-input-synaptics. It can only spoil the system and break dependencies. libinput is used as a user space driver in Ubuntu 20.04. I suggest removing that package. 2) If your touchpad is not shown in xinput it makes no sense at all trying to tinker with user space drivers. The problem is with the kernel support. Most likely this touchpad is not supported yet, or needs some kernel option to workaround it. The latter is unlikely.
    – Pilot6
    Jun 4 '20 at 20:04
  • Are you sure you don't have a Logitech mouse attached? Please add the full output of xinput to your question.
    – Pilot6
    Jun 4 '20 at 20:06
  • Ok, I'll try to uninstall the synaptics package. I was trying to follow wiki.ubuntu.com/…;
    – Nandete82
    Jun 4 '20 at 20:14
  • Why do you think the touchpad is detected as a Logitech mouse? Are you using a mouse? It looks like the touchpad is not detected at all.
    – Pilot6
    Jun 4 '20 at 20:14
  • 1
    I have uninstall the xorg package and now the touchpad is recognised. Thanks a lot; I restarted the laptop and now it is working!! It doesn't have all the functions, but I can scroll again.
    – Nandete82
    Jun 4 '20 at 20:24
3

I've removed xserver-xorg-input-synaptics, unplugged the auxiliary mouse and restart the laptop.

The touchpad is recognised and the main functions working.

Thanks Pilot6 for the help.

0
2

For my Lenovo IdeaPad 5 15IIL05 - i5-1035G1 Michael Reutman's (mreutman) solution in launchpad worked like a charm. I had to:

  1. Edit /etc/default/grub (with nano /etc/default/grub) and change the following line as shown:

    GRUB_CMDLINE_LINUX_DEFAULT="i8042.nopnp=1 pci=nocrs quiet splash"
    
  2. Update GRUB:

    update-grub
    
  3. Reboot.

0
0

The ONLY way I can get my trackpads to function properly on my Thinkpad t469 and t15 is to install xserver-xorg-input-synaptics

1
  • My laptop is a Lenovo ideapad Y700. I still need to restart the touchpad several times after login to have the scrolling function, but synaptic drivers were making the issue worst. It is a know bug and until it's resolved, we need to live with it! I'm thinking about installing Fusuma...
    – Nandete82
    Jun 29 '20 at 14:17
0

The above method just made wifi disappear on reboot and touch-pad didnt work IdeaPadGaming3 AMD 4600H / 1650Ti

2
  • 1
    This is more of a comment than an answer. Given that answers can change position based on votes and acceptance, “above” will be seen as vague. Perhaps this would be an opportunity to create a question for your specific situation?
    – user1091774
    Jan 3 at 7:28
  • Actually The bug iam facing falls under MSFT trackpad bugs.launchpad.net/ubuntu/+source/linux/+bug/1887190 i have reported that it affects me as well hope in future kernel releases this is fixed , i tried kernel 5.10.4 generic it caused a bug with D-GPU xserver settings didnt open and launch an app with D-GPU didnt show up.
    – bCi
    Jan 3 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.