2

How do I disable Ctrl-Alt-Del logout in Ubuntu 20.04?

I followed this guide using these commands:

systemctl mask ctrl-alt-del.target
systemctl daemon-reload

However, the key combination is still working afterward.

The reason I'd like it disabled is because my keyboard & mouse is shared between my Linux machine and a Windows machine that requires Ctrl-Alt-Del to unlock. If my keyboard is accidentally still connected to my Linux machine, it will logout.

1
2

Open "Settings - Keyboard Shortcuts". Look up the entry "Log out" under the "System" section, and disable the keybinding. That works by clicking the line, then hit Backspace in the "Set Shortcut" dialog. Then click "Set" to apply the setting and close the dialog.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.