4

I use Ubuntu over a Manhattan KVM switch (8-port HDMI) that worked perfectly with Ubuntu 18.04. I performed an update from 18.04 to 20.04 and my mouse and keyboard (connected over the KVM switch) stopped working.

I tried to reproduce the issue with another system and got the same: not-working keyboard and mouse.

lsusb shows the KVM-switch as Logitech Unifying Receiver.

Do I need to load a specific kernel module?

Currently logitech-djreceiver is loaded according the dmesg output. I did attach another mouse and keyboard. These make use of hid-generic and work. Did anyone face a similar situation? Are there any ideas for solving the issue?

1
  • I tried the live system of Ubuntu 20.04 and get the same issue. Jun 4, 2020 at 22:46

3 Answers 3

5

If removing the kernel module fixes the issue, why not just blacklist the entire module from loading at boot?

$ sudo su
# echo "blacklist hid_logitech_dj" >> /etc/modprobe.d/blacklist.conf
# update-initramfs -u

Then reboot, and it shouldn't load the module any further while booting.

0

The vendor and product id of the KVM switch are 046D:C534. The driver hid_logitech_dj shows that id when running modinfo.

A workaround: I created a shellscript /root/bin/rmlogitech-dj.sh

#!/bin/bash
/sbin/rmmod hid_logitech_dj

I run that script @reboot in cron as root:

@reboot /root/bin/rmlogitech-dj.sh
0

I just put the line

/sbin/rmmod hid_logitech_dj 

in /etc/rc.local (above the line exit 0). That way by the time I get to the login page, the hid_logitech_dj module is removed already.

The problem I have is that I have to type a password to decrypt the disk during boot, and unfortunately, it looks like the hid_logitech_dj module is still loaded at that time, so my keyboard won't work through my Keyboard-video-mouse KVM. I have to unplug my usb keyboard from the KVM and plug it directly into one of the USB Ports on the motherboard/case.

(I would be interested to know why the hid_logitech_dj module causes this problem in the first place, and if there a bug report on this.)

1
  • Hi Mike, rc.local executes at the end of the multiuser runlevel. Can you try to run the script in a lower runlevel? Jun 22, 2020 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.