0

When I try to control the volume of sound on my computer, the system volume does not seem to make any difference. Instead, each application has its own volume control in settings, as shown in the following screenshot:

Multiple volume sliders

I would like to control all audio using the main system volume control, does anyone know how can I disable this per application setting please? Thank you.

  • Version: 20.04
  • Hardware: iMac early 2015
0
0

You have to set the flat-volumes option to no in the ~/.pulse/daemon.conf:

$ cat ~/.pulse/daemon.conf
...
flat-volumes = no
...

From man pulse-daemon.conf

flat-volumes= Enable 'flat' volumes, i.e. where possible let the sink volume equal the maximum of the volumes of the inputs connected to it. Takes a boolean argument, defaults to yes.

Then restart the daemon :

pulseaudio -k ; pulseaudio -D

I had a similar problem and that worked for me.

Read more about it here.

1
  • Thanks for taking the time to answer. Unfortunately it doesn't seem to make any difference if I have "flat-volumes" set to "no" or not, some applications just decide to output at full volume anyway (such as Slack). I wish there was a way to revert to older behaviour where a single master volume controlled all volumes. – da_n Jun 15 '20 at 7:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.