5

I have installed Ubuntu 20.04 LTS successful on a Raspberry Pi 4.

However I cannot get the Bluetooth to work. In settings it says no Bluetooth found - plug in a dongle to use.

I have an identical Raspberry Pi 4 running Raspian and the Bluetooth works fine. When I run Bluetooth manager it just runs and closes.

3

3 Answers 3

10

I found an answer for this on the raspberry pi forum - very simple: Install the pi-bluetooth package:

sudo apt install pi-bluetooth
sudo reboot
2
  • i can confirm this solution works (even in server environment)
    – dark_ruby
    Nov 7, 2020 at 18:26
  • 1
    This worked once but after updating OS to Ubuntu 20.10 (codename Groogy), the device rebooted and since then bluetooth is completely gone bonks
    – Azz
    Feb 19, 2021 at 21:45
1

I was able to get it working following the answer here but I found I needed to run the attach command twice:

$ sudo hciattach /dev/ttyAMA0 bcm43xx 921600 -
bcm43xx_init
Initialization timed out.

$ sudo hciattach /dev/ttyAMA0 bcm43xx 921600 -
bcm43xx_init
Set Controller UART speed to 921600 bit/s
Flash firmware /etc/firmware/brcm/BCM4345C0.hcd
Set Controller UART speed to 921600 bit/s
Device setup complete
0

This command worked for me in ubuntu 20.10 for raspberry pi 4 when I had removed the number 921600 from the previous answer by Ian Mercer.

sudo hciattach /dev/ttyAMA0 bcm43xx

Not the answer you're looking for? Browse other questions tagged or ask your own question.