21

It seems to be a common issue but I could not find a solution.

  • just clean installed Ubuntu 20.04 Desktop and updated it with the "Software & updates" tool.
  • PC:HP ProDesk 400 G4 Desktop-Mini-PC
  • The monitor attached on one of the DisplayPort ports: HP EliteDisplay E243
  • Video card (lspci -k | grep -A 2 -i "VGA") :
00:02.0 VGA compatible controller: Intel Corporation 8th Gen Core Processor Gaussian Mixture Model
    DeviceName: Onboard IGD
    Subsystem: Hewlett-Packard Company 8th Gen Core Processor Gaussian Mixture Model
  • output of command seen on other related questions/answers :
xrandr --query
Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 16384 x 16384
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
DP-3 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200     59.95*+
   1920x1080     60.00  
   1600x1200     60.00  
   1680x1050     59.95  
   1280x1024     60.02  
   1280x960      60.00  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  
   720x400       70.08  
HDMI-3 disconnected (normal left inverted right x axis y axis)
  • The configuration was working out-of-the-box on Windows 10 and Debian 10.
  • I could not find anything obviously wrong in the dmesg output.
  • (edit) I also tried to change grub to add nomodeset it does not make any difference.
  • (edit) I tried switching to lightDM (and back to gdm, +reboot) but no difference noticed.
  • (edit) I also did an update with sudo apt update ; sudo apt upgrade but no change.
  • (edit) I upgraded the kernel to the last stable (5.6.16) but without effect.

If some extra info is needed please let me know.

6
  • 1
    Have you found a solution ? I am facing the same issue
    – Alarid
    Jul 1, 2020 at 8:24
  • Unfortunately not. my current belief is that the DP ports on the motherboard have been rendered inoperable since the ubuntu install (I tried using the debian live usb that was working with two screens but since then only one is working anymore). Since this happened when I installed Ubuntu I suppose something went wrong during the installation. Now I don't know how to confirm it, and I am afraid it won't fix it anyway. I hope you do have another, less permanent, issue. Jul 2, 2020 at 23:59
  • I see. There must be a way to fix this, I believe there always is.. Maybe try posting on Ubuntu forums ? I don't really know if my issue is similar to yours, it's a bit weird : I managed ONCE to make my second monitor work, I can't remember how cause I tried many things, and the next reboot it was back to not detected. Maybe the next nvidia or ubuntu updates will fix this.
    – Alarid
    Jul 4, 2020 at 13:04
  • How similar is your configuration? you have the same PC, mine does not have an nvidia card, it is the intel card included with the motherboard. Since then I tried the Debian which was working (live usb stick) and I also put back the windows 10 drive back, in both case the monitor is no longer detected. Hence I think the hardware is damaged; HP made a proposal to replace the motherboard but it is the same price as I paid for the PC in the first place. Hence I think there is not much to be done as most likely the hardware is fried. Jul 6, 2020 at 16:01
  • Having the same issue, with most of the same sensors you tried (xrandr --query showing HDMI "disconnected"). But here's the weird thing: Windows 10 which I'm dual-booting with a Truly Portable external USB SSD shows the HDMI port just fine! And, using a different monitor, getting the failure results on a 55" Samsung TV connected via HDMI cable, I get both laptop display and HDMI displaying!? So I won't be thinking of hardware issues. Any way to reinstall HDMI "drivers" you know of?
    – AlMo320
    Aug 20, 2020 at 0:06

5 Answers 5

15

Check if you have the latest drivers

sudo ubuntu-drivers autoinstall

Then check for your additional drivers. Try to go to

  • Software & updates
  • Additional Drivers (And there you see your drivers.)
  • Change your card driver then press apply (even if it is a good driver),
  • Then change again to the latest driver.
  • reboot

This resolved my issue, I think ubuntu did not recognize drivers because of some updates.

Hope it helps.

5
  • Unfortunately I did that already. I guess you had a slightly different issue. Anyway thank you for trying to help me. Sep 29, 2020 at 17:03
  • 1
    Solved it for me... it was working for a long time, and stopped working out of the blue. This fixed it! Oct 5, 2020 at 12:41
  • 1
    Yes it helped me greatly. This website was also helpful: linuxize.com/post/how-to-nvidia-drivers-on-ubuntu-20-04
    – LeSchwambo
    Dec 22, 2020 at 13:56
  • Did not have to go through the Software & Updates part, only the first command and reboot.
    – AymDev
    Mar 12, 2021 at 17:24
  • 2
    This was flawless. Brilliant solution. [+10] Mar 18, 2021 at 16:13
3

I have Ubuntu studio 20.04. I upgraded my ASUS motherboard BIOS and one of my two monitors stopped working. I looked at the output of dmesg and it showed this:
[ 50.822389] Lockdown: Xorg: raw io port access is restricted; see man kernel_lockdown.7

Some googling showed that the BIOS UEFI safe boot locks the kernel and won't allow the Nvidia drivers to load. Dual boot won't work either with a safe boot.

I followed these instructions to remove safe boot: How To Disable Secure Boot on an ASUS Motherboard. After rebooting both monitors were working.

2
  • Hi Stuart, thanks for pitching in, unfortunately it seems our problems are different: I do not have such message in dmesg, also I don't have nvidia card or driver only the one included in the intel cpu. For other purposes I booted in secure and non-secure boot, however there was no change for the status of the second monitor. Oct 23, 2020 at 14:52
  • That happened to me as well after my Windows dual boot updated the BIOS during a System update (sigh). Turning off Secure Boot gave me back my two screens.
    – Matthieu
    May 4, 2021 at 13:15
3

Just spent hours trying to fix the same problem. Didn't realize I was using a directional HDMI cable.

Please flip your cables around before going crazy looking for solutions, it may be as easy as that...

2

I fixed it by upgrading to Ubuntu 20.10 with kernel version 5.8

1

Faced this problem today. Solved with below steps

  1. Created Ubuntu USB startup disk with ubuntu-21.10-desktop-amd64.iso
  2. Boot USB selected required options and also provided wifi password. Checked Ubuntu updates download and third party software download.
  3. Reached to step where I had to select one of the radio a. Fresh Install 2. along side Ubuntu 20.04 ( my current ). Did not select any option and quit installation from this point and powered off.
  4. Next boot of 20.04 detected my external monitor :-)

Good Luck. Keep sharing tips, trick and solutions and help whenever we can.

2
  • Thanks for sharing Nitin. What's the trick? Why it will work? What has changed to your Ubuntu 20.04? I'm clueless why it is suddenly working. thx.
    – xpt
    Nov 1, 2021 at 18:39
  • Thought process : 1. Boot time immediately after bios reading screen is detected. Also even if os not installed screen greys detected. That mean first thing during boot in os or that independent partition like 512mb to 1gb has some component which didn't work. Then why not to check hardware with installable ununtu usb. Tried and then it should have reset some package or component responsible for detecting driver.
    – Nitin
    Nov 2, 2021 at 23:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.