1

So I have a major problem with PulseAudio. When any app play sound (from a media player to a system sound, and even the volume change sound or a virtual machine through VirtualBox), it makes the app freeze for 10 seconds and play the sound.

It happens only if no sound played since a short time (if I listen to music there is no freezes for any app) and it's very annoying...

Here's what I already tried:

  1. Rebooting, of course, because reboot fix most problems, but not mine...
  2. sudo apt install pulseaudio-module-jack and insert this into /etc/pulse/default.pa:
load-module module-jack-sink
load-module module-jack-source
  1. Uninstall (sudo apt purge --auto-remove pulseaudio* alsa*) and reinstall PulseAudio (and ALSA and everything related)
    • I don't have this problem if I uninstall PulseAudio
  2. Checking system logs (/var/log/syslog) → nothing related to PulseAudio or ALSA
  3. Tried to play through mplayer or another command-line audio player. The problem is still there and no error message.

I finally gave up, waiting for a solution, or switching back to Windows if the problem persists (because I do a lot of audio-related things so it's major for me). Searching on Internet didn't help, it seems like nobody have the (exact) same problem... Note that the sound was perfectly working 1 week ago (and when I tested the beta of Ubuntu 20.04), and I didn't changed something sound-related.

If this may help, I installed other desktops on my system (Xfce and a not-fully uninstalled KDE) which may conflict with PulseAudio.

I hope there is a solution that don't need me to reinstall everything, it's the last thing I will do if I don't have a solution.

Regards.

0

After a bit research, I was running a lowlatency kernel (which I manually installed). Switching back to a generic kernel fixed the problem.

If you manually installed a lowlatency (or another) kernel, you can use GRUB recovery options to start a specific kernel:

  • If you see the GRUB menu when you boot, just select « Advanced options for Ubuntu » and select a generic kernel.
  • If you don't see the GRUB menu when you boot normally, press Esc at the early boot process (between POST [the end of hardware initialization process] and real system boot). This will open the GRUB menu, where you can select « Advanced options for Ubuntu » and boot a generic kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.