I have installed Vuze on Ubuntu 11.04.Everything is working fine.But when I close Vuze and try to reopen it, it won't open. If I restart the system and try opening Vuze it would open normally. So can someone tell me what is the problem here and how to solve this?

  • I'm facing the same problem with Vuze in Ubuntu 12.04. Is there anyone who can help in this regard?
    – tuxtu
    Sep 13, 2012 at 3:14

5 Answers 5


If you close it the process will keep running up & (seeding & downloading) you can kill the process

pidof Java
kill <pid number>

or you can use "system monitor" enter image description here

this picture shows you that "Java" is running App name "Azureus" ("Vuze" is an app made by "Azureus")

after killing the process the you can open "Vuze" again

(Sorry I was not a member in the time that you asked this question)

or you can make a "Bash" script (just like i did)

check if the "Java" process is running close it open the "Vuze" else open the "Vuze" directly (Pid variable)
then make a luncher to this script Using "gnome-desktop-item-edit" in the command type if it is a shell script "sh filename.sh" or elseif python "python filname.py"

You can help the "Azureus" by sharing this info that the app is not closing correctly (reporting the bug)


Mostly it's a bug! And it's still not fixed until this day. I have vuze on Ubuntu 13.10 and I have your problem! Anyways I have a solution for you.

Try closing it not from the x button but from the "close" button in the "file" menu up to the left then try reopening it. It should open normally and it even won't display the message at the bottom right corner that says that "vuze wasn't shut down correctly". I hope this helps


Actually this is the problem in the design of vuze. If you close vuze it is never actually closed. It runs in background with a process name java. To see that you open the system monitor and see the running processes then you will see the java process corresponding to the vuze. To deal with this problem you have to change the setting of the vuze to stop running in background once closed. Go to tools->options->interface then uncheck the close minimizes to system tray...


I got a work around... Just open a .vuze file and it shows up. Looks like its been running the entire time... I'm new to Ubuntu so I don't know the terminal commands all that well. Hope this works for you.

  • 1
    @ karthik Venkatesan, Please make your answer more clear. Thanks.
    – tuxtu
    Sep 10, 2012 at 18:20
  • do you mean a ".torrent" file? Jan 14, 2014 at 0:01

Vuze tries to minimize itself to the 'system tray' when closed. With Vuze this no longer works since Ubuntu 11.04 and persists until 14.04.

To prevent this behaviour, in Options -> Interface deselect the "Close minimizes to system tray" option to prevent Vuze to stay open in the background.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.