6

TL;DR

I got the inspiration for the solution from the answer here: https://askubuntu.com/a/862896/39456, I found this question through the proposed solution by @laugeo: thanks for the hint with the codec, mine wasn't on the list.

The problem

Until last week-end I had still sound on my PC. Then after an update: no more sound. What is strange though, I booted up the PC yesterday with the live image of Ubuntu 20.04 and there I have sound!

Since then I tried already the following tips an tricks without success:

Again, booting into the live Ubuntu 20.04 gives me sound, booting from hard drive gives nothing.

What else I tried was to plug the speakers into the screen (HDMI), but still silence. Although the parameters window for the speaker shows that there is sound played, just not for real.

Here's my setup:

lspci |grep 'Audio'
1d:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
1f:00.3 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD Audio Controller

Has anyone any idea how I can get the sound back? Because, as mentioned, the sound was there until last week-end.

The solution

In pavucontrol under the Configuration tab I changed the Profile for my sound card to Analog Stereo Duplex and then under the Output tab I switched the port to the right one. Sound is back!

4
  • look 1st answer here : askubuntu.com/questions/1243359/…
    – laugeo
    Jun 3 '20 at 19:30
  • @laugeo unfortunately nope, didn't work either Jun 4 '20 at 8:27
  • do you see all faders in alsamixer ? or do you need to press F6 and select 2nd sound device to see them ?
    – laugeo
    Jun 4 '20 at 8:38
  • @laugeo Yes, every time i launch alsamixer I do indeed see first the HDMI output and I have to switch with F6 to the generic one (which I "use") Jun 4 '20 at 9:37
1

Various checks:

  • In pavucontrol , does vumeter move when playing ? As your sound device is the 2nd one (as seen in alsamixer) , I suppose you know that you must select it as default in devices tab with green button .

  • After that and if you have dual boot , check fastboot is disabled in windows .

  • As you have problem since update, the new alsa driver may need additional parameter :
    you can try to check your codec model :
    cat /proc/asound/card0/codec#* |grep Cod
    Then search your codec here or here and from the available models under this codec, add line with a similar model to your pc at the end of file:
    /etc/modprobe.d/alsa-base.conf
    F.i. if codec is ALC898 and pc is Lenovo Yoga:
    options snd-hda-intel model=lenovo-y530
    Try also
    options snd-hda-intel model=auto

Command to check codec errors at boot:
dmesg |grep codec

3
  • Thank you for your efforts, your hint with the codec helped me (mostly because he doesn't figure on the list) to find the question / Answer which solved my problem Jun 4 '20 at 14:00
  • cool, it would be interesting that you make answer and accept it youself , or at least give your codec name and the link to the question/answer
    – laugeo
    Jun 5 '20 at 8:21
  • uh, i didn't saw that you had already edited your question
    – laugeo
    Jun 5 '20 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.