2

My mate-weather applet suddenly stopped working. Have tried other locations, none work. Has anyone else encountered this and do you know of a fix?

Seen on Ubuntu 16.04 LTS, MATE 1.18 and on Ubuntu 20.04 LTS, MATE 1.22.

7
  • FYI: Ubuntu MATE 16.04 LTS being a flavor of Ubuntu had only 3 years of supported life (fridge.ubuntu.com/2019/03/01/ubuntu-16-04-6-lts-released) which ended 2019-April. Ubuntu 16.04 LTS Server (no desktop) or Desktop (Unity 7) have 5 years of supported life and are still supported. Refer release notes, or use ubuntu-support-status or your own system to confirm this is the case. I suggest you move to a supported release of Ubuntu-MATE for security reasons, unless you're off-line or are aware of risks. ubuntu-mate.community/t/… – guiverc Jun 3 '20 at 3:45
  • @guiverc really it happens on 20.04 LTS too. – N0rbert Jun 3 '20 at 8:06
  • The backend here is aviationweather.gov . So please STOP closing this question as duplicate because it does not use openweather !!! And STOP closing it as off-topic because It exists in all Ubuntu versions !!! – N0rbert Jun 3 '20 at 8:18
  • @N0rbert my comment is FYI as I don't vote EOL on partially-supported (flavor LTS) releases. I think the FYI is worthwhile as so many unofficial sites still say flavors come with 5 years (as main Ubuntu does) which is & has always been untrue (with minor exceptions, eg. Kylin on 16.04 had 5 years sponsored by Canonical) – guiverc Jun 3 '20 at 8:23
  • 1
    @AlBrundage see updated answer. I prepared one line binary patch. – N0rbert Jun 10 '20 at 8:03
2

Update 2020-06-24: problem is solved on server-side. No additional manual actions required.


This is aviationweather.gov server side issue, which now is in the works.

The Ubuntu MATE community also knows about the issue, the pull request is prepared.

Please wait for resolution.

Note: all current Ubuntu MATE versions are affected. And not only MATE, as the aviationweather.gov is used by some other Ubuntu projects.


For those who do not want to wait there are two possible solutions.

  • Patch the MATE Weather library on binary level with single command below:

    • 64 bit

      sudo sed -i 's|https://www.aviationweather.gov/adds/dataserver_current/httpparam|https://www.aviationweather.gov/adds/dataserver1_3/httpparam\x0\x0\x0\x0\x0|' $(readlink -f /usr/lib/x86_64-linux-gnu/libmateweather.so.1)

    • 32 bit

      sudo sed -i 's|https://www.aviationweather.gov/adds/dataserver_current/httpparam|https://www.aviationweather.gov/adds/dataserver1_3/httpparam\x0\x0\x0\x0\x0|' $(readlink -f /usr/lib/i386-linux-gnu/libmateweather.so.1)

    Note: to revert the patch one can reinstall the corresponding package with sudo apt-get install --reinstall libmateweather1.

  • Use My Weather Indicator applet from Atareo PPA by one of the following methods:

    • by adding PPA

      sudo add-apt-repository ppa:atareao/atareao
      sudo apt-get update
      sudo apt-get install my-weather-indicator
      
    • by downloading package manually:

      cd ~/Downloads
      wget https://launchpad.net/~atareao/+archive/ubuntu/atareao/+files/my-weather-indicator_0.9.4-0extras19.10.09_all.deb
      sudo apt-get install ./my-weather-indicator_0.9.4-0extras19.10.09_all.deb
      

    and then find the application in the Applications → Accessories → My-Weather-Indicator and set settings for it.
    Optionally you can add it to autostart by placing the corresponding desktop-file in the correct directory:

    mkdir -p ~/.config/autostart
    cat << EOF > ~/.config/autostart/my-weather-indicator.desktop
    [Desktop Entry]
    Type=Application
    Exec=/opt/extras.ubuntu.com/my-weather-indicator/bin/my-weather-indicator
    Hidden=false
    X-MATE-Autostart-enabled=true
    Name=My Weather Indicator
    EOF
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.