My 64bits desktop (intel core i7) was able to boot with Windows XP 64 installed, but it's not more possible after installing Ubuntu amd64: the computer says the HD is not bootable. The only way of booting the computer now, is using the Live CD and choosing boot from the hard disk. Besides, if I put this HD in a 32bits computer, grub boots normally. How can I enable boot directly from the HD using the 64bits desktop?

  • Did you really mean that you have an intel cpu and installed an amd distribution? I'm not sure this is a bad idea but it sounds like it could cause problems.
    – msw
    Nov 10 '10 at 12:56
  • 1
    @msw: "amd64" stands for "x86-64" and simply means "64-bit". It has nothing to do with the processor's vendor.
    – htorque
    Nov 10 '10 at 13:07
  • Can you show us the output of fdisk -l /dev/sdX (replace X with the right letter for your hard disk - see the above linked guide, if you don't know how to find out).
    – htorque
    Nov 10 '10 at 15:30
  • This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. I am flagging this for closure :)
    – Ringtail
    Mar 1 '12 at 18:02

Sounds like you need to reinstall grub (or at least have it embedded on the MBR). Grub does usually work fine in a 64bit environment (at least it works here).

There are a lot of guides out there for doing this but most concern Grub v1. Ubuntu has been on Grub v2 (confusingly the actual version number is 1.9x) for a while and the repair instructions are slightly different.

If I were you, I'd follow this guide and see where you get.

  • I'll follow your suggestion with the guide, but I've already tried the SIMPLEST method and I was unable to solve it. Also, I tried to restore mbr using "fixboot /mbr" with a Windows installation CD and nothing happened. However, in a 32bits computer, everything proceeds as expected. Is there a possibility of a bug in the firmware of the BIOS?
    – Vitor
    Nov 10 '10 at 14:35
  • fixboot will kill grub. It's possible a BIOS firmware issue. What's the motherboard?
    – Oli
    Nov 10 '10 at 14:44
  • Right, fixboot will kill grub (mbr) and this was the intention as the original configuration (with Windows XP 64) was booting ok. It was just a try to see if the computer boots with a mbr from Windows, but it was not. Weird!
    – Vitor
    Nov 10 '10 at 14:50
  • The motherboard is an Intel DX58SO.
    – Vitor
    Nov 10 '10 at 15:10
  • Here a user successfully installed Ubuntu 8.10 x64 on the Intel DX58SO: bugs.launchpad.net/ubuntu/+bug/317607
    – htorque
    Nov 10 '10 at 15:22

Just saw the line:

I put this HD in a 32bits computer, grub boots normally

That (paired with it booting from the CD) suggests that your BIOS is looking at the wrong drive to boot. Check that this disk is the primary boot device.

  • Agree, that would also explain why he can boot the installation via the live CD.
    – htorque
    Nov 10 '10 at 13:54
  • I checked the boot order (HD first), and also chose manually to boot from the HD. In both cases, if there is no CD inside, I receive the message "The drive is not bootable"; if there is the CD, it proceeds to boot the Live CD normally.
    – Vitor
    Nov 10 '10 at 14:27
  • @Vitor Then there might be something messed up with grub. Work through the grub restoration guide in my other post.
    – Oli
    Nov 10 '10 at 14:29
  • Just to add information, I installed grub many times as a consequence of installing Debian 5.0 amd64, Ubuntu 9.04 amd65, Kubuntu 9.10 and Kubuntu 10.10 amd64. None of the installations allowed me to boot in the 64bits desktop, but just in a 32bits.
    – Vitor
    Nov 10 '10 at 14:47

Following my last comment, I googled for your motherboard and "boot flag", and in fact the Intel DX58SO doesn't boot, if there is no primary partition with the boot flag set.

You can check this with:

fdisk -l /dev/sdX

If no partition has an asterix (*) in the 'boot.' column, then that's the problem.

To fix this, you can use GParted from the live CD:

  • Right click any primary partition
  • Select 'Manage Flags'
  • Tick the 'boot' flag
  • Click on 'Close'

You're done.

  • Ok. I didn't put the result of the command yet because the server is running Windows and it cannot be stopped at this moment. I'll check this as soon as possible.
    – Vitor
    Nov 10 '10 at 18:00
  • /dev/sda5 * 58337 60693 18932571 83 Linux My logical /dev/sda5 partition has an asterix, and is where Linux is installed. But there still exist the possibility of BIOS needing a primary partition with boot flag, instead of a logical one.
    – Vitor
    Nov 11 '10 at 15:16
  • And I'll have to wait some more weeks to perform this test.
    – Vitor
    Nov 11 '10 at 15:17
  • The page where I found this (German -> English translation) explicitly stated it needs a primary partition with the boot flag set. Hope it helps! :)
    – htorque
    Nov 11 '10 at 16:17

You could try a nifty software called boot repair from any thing that boots and try to manage all the os from there.Be it MBR or grub

Just have a try