1

Since I installed Ubuntu 20.04 I cannot get sound from the audio jack. The internal speakers of my Asus X301A laptop work. When I plug in the audio a loud noise sound is emitted from the audio system but not what the laptop is playing.

Before plugging the jack:

$ pacmd list | grep "active port"
    active port: <analog-output-speaker>
    active port: <analog-input-internal-mic>

After:

$ pacmd list | grep "active port"
    active port: <analog-output-headphones>
    active port: <analog-input-internal-mic>

Hardware information:

$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)

$ cat /proc/asound/pcm
00-00: ALC270 Analog : ALC270 Analog : playback 1 : capture 1
00-03: HDMI 0 : HDMI 0 : playback 1

Software information:

$ dpkg -l *alsa*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                 Version              Architecture Description
+++-====================-====================-============-=========================================
un  alsa                 <none>               <none>       (no description available)
ii  alsa-base            1.0.25+dfsg-0ubuntu5 all          ALSA driver configuration files
un  alsa-oss             <none>               <none>       (no description available)
ii  alsa-topology-conf   1.2.2-1              all          ALSA topology configuration files
ii  alsa-ucm-conf        1.2.2-1              all          ALSA Use Case Manager configuration files
ii  alsa-utils           1.2.2-1ubuntu1       amd64        Utilities for configuring and using ALSA
un  bluez-alsa           <none>               <none>       (no description available)
un  gstreamer1.0-alsa    <none>               <none>       (no description available)
un  libsdl1.2debian-alsa <none>               <none>       (no description available)


$ uname -a
Linux X301A1 5.4.0-33-generic #37-Ubuntu SMP Thu May 21 12:53:59 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04 LTS
Release:    20.04
Codename:   focal

What I have tried:

  • Checked that alsamixer does not have auto-mute enabled
  • Tried all the available outputs in the Sound configuration panel
  • Installed and tried pavuctonrol

How do I get sound from the audio-jack?

  • Sound (through jack) works when using a Ubuntu 18.04 live USB, does not when using a Ubuntu 20.04 live USB – Victor Lamoine Jun 4 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.