35

I'm following the official guide to install Docker.

And in step 2 Add Docker’s official GPG key, I got the following error:

$ curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
gpg: invalid key resource URL '/tmp/apt-key-gpghome.Rcg4Lpatvi/home:manuelschneid3r.asc.gpg'
gpg: keyblock resource '(null)': General error
gpg: key 1488EB46E192A257: 1 signature not checked due to a missing key
gpg: key 3B4FE6ACC0B21F32: 3 signatures not checked due to missing keys
gpg: key D94AA3F0EFE21092: 3 signatures not checked due to missing keys
gpg: key 871920D1991BC93C: 1 signature not checked due to a missing key
gpg: Total number processed: 9
gpg:       skipped new keys: 9

How do I solve that?

2
  • Just for context, I encountered the same issue and solved it by removing that manuelschneid3r key. And this key seems to be imported when I was trying to install the albert launcher. (albertlauncher.github.io/installing) I guess everyone here should be using albert as well. what a coincidence.
    – hzh
    Jun 25, 2021 at 21:50
  • Author here. See this article on this issue. Jul 13, 2022 at 10:18

4 Answers 4

75

This issue can be fixed by doing:

sudo rm "/etc/apt/trusted.gpg.d/home\:manuelschneid3r.gpg"

Or

sudo rm "/etc/apt/trusted.gpg.d/home\:manuelschneid3r.asc"

This could be due to installing the Albert launcher, here is a related issue. Thanks to Sasgorilla in the comments

8
  • I ran into this issue when trying to install podman(podman.io/getting-started/installation.html) onto ubuntu and this allowed me to get it installed.
    – Kuberchaun
    Sep 7, 2020 at 8:24
  • 1
    How did you find out this?
    – Felipe
    Oct 19, 2020 at 17:38
  • This worked for me as well. It was causing also zerotier-cli installation to fail due NO_PUBKEY 1657198823E52A61 error. Thanks a lot! Nov 13, 2020 at 10:21
  • 5
    Pretty sure this results from installing the Albert launcher. I've opened up an issue for it there.
    – Sasgorilla
    Jun 24, 2021 at 15:27
  • 3
    In my case the command was slightly different: sudo rm "/etc/apt/trusted.gpg.d/home:manuelschneid3r.asc". Look in /etc/apt/trusted.gpg.d/ for the problematic key.
    – Sasgorilla
    Jun 24, 2021 at 15:32
5

Got this error while installing MongoDB. Following worked for me.

sudo rm /etc/apt/trusted.gpg.d/home:manuelschneid3r.gpg

1
1

Note that this answer is a copy of the answer in this article.


-- Theres not much you can do about expired keys, but to get a new valid one. Seems easy but still there are some caveats.

Note that multiple keys have been distributed in the past: the global key and a key for each distribution. Also recommended code snippets in the past put the keys in different locations (/etc/apt/trusted.gpg and /etc/apt/trusted.gpg.d/[…]).

This tutorial will try to fix all possible issues and get apt to work again.

1. Keys embedded in /etc/apt/trusted.gpg

Use apt-key del <id> to remove the key. Find the id of the repo home:manuelschneid3r using apt-key list.

# apt-key list
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
/etc/apt/trusted.gpg
--------------------
pub   rsa2048 2017-10-27 [SC] [expired: 2022-03-05]
      A4B8 3CD0 5FDF 5C51 7848  2D4A 1488 BLAA E192 A257
uid           [ expired] home:manuelschneid3r OBS Project <home:[email protected]>

[…]

# apt-key del "A4B8 3CD0 5FDF 5C51 7848  2D4A 1488 BLAA E192 A257"

2. Keys in /etc/apt/trusted.gpg.d/

Remove any keys related to Albert in /etc/apt/trusted.gpg.d/. Note that, depending on the snippet you used to install albert, this keys may have obscure names. If you used the snipped on the official software center at OBS, the file is likely to have the name home_manuelschneid3r.gpg.

rm /etc/apt/trusted.gpg.d/home_manuelschneid3r.gpg 
3. Sources list

apt will now refuse to work with the error

The following signatures couldn't be verified because the public key is not available: NO_PUBKEY …

If you want to keep albert, you can fetch a new key now. This is exactly what you did when you initially installed albert. Visit the OBS software center for the code snippet.

If you dont need albert anymore, remove the repository from your sources by removing either the relevant line in /etc/apt/sources.list or the file /etc/apt/sources.list.d/home:manuelschneid3r.list, depending on how you installed albert.

You're done. Have fun using albert 🍻

0

I had the same issue. In my case, in the same directory /etc/apt/trusted.gpg.d I had .asc file just named differently. Once I renamed the .asc file by chaning its extension I was able to add Docker's gpg keys.

1
  • 1
    To be more precise, use this curl -fsSL https://download.docker.com/linux/ubuntu/gpg > /etc/apt/trusted.gpg.d/docker.asc
    – nagylzs
    Jul 10, 2020 at 5:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .