33

I'm following the official guide to install Docker.

And in step 2 Add Docker’s official GPG key, I got the following error:

$ curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
gpg: invalid key resource URL '/tmp/apt-key-gpghome.Rcg4Lpatvi/home:manuelschneid3r.asc.gpg'
gpg: keyblock resource '(null)': General error
gpg: key 1488EB46E192A257: 1 signature not checked due to a missing key
gpg: key 3B4FE6ACC0B21F32: 3 signatures not checked due to missing keys
gpg: key D94AA3F0EFE21092: 3 signatures not checked due to missing keys
gpg: key 871920D1991BC93C: 1 signature not checked due to a missing key
gpg: Total number processed: 9
gpg:       skipped new keys: 9

How do I solve that?

1
  • Just for context, I encountered the same issue and solved it by removing that manuelschneid3r key. And this key seems to be imported when I was trying to install the albert launcher. (albertlauncher.github.io/installing) I guess everyone here should be using albert as well. what a coincidence. Jun 25 at 21:50
61

I recently had the same issue and fixed it by doing

sudo rm "/etc/apt/trusted.gpg.d/home:manuelschneid3r.gpg"
6
  • I ran into this issue when trying to install podman(podman.io/getting-started/installation.html) onto ubuntu and this allowed me to get it installed.
    – Kuberchaun
    Sep 7 '20 at 8:24
  • How did you find out this?
    – Felipe
    Oct 19 '20 at 17:38
  • This worked for me as well. It was causing also zerotier-cli installation to fail due NO_PUBKEY 1657198823E52A61 error. Thanks a lot! Nov 13 '20 at 10:21
  • 2
    Pretty sure this results from installing the Albert launcher. I've opened up an issue for it there.
    – Sasgorilla
    Jun 24 at 15:27
  • 1
    In my case the command was slightly different: sudo rm "/etc/apt/trusted.gpg.d/home:manuelschneid3r.asc". Look in /etc/apt/trusted.gpg.d/ for the problematic key.
    – Sasgorilla
    Jun 24 at 15:32
4

Got this error while installing MongoDB. Following worked for me.

sudo rm /etc/apt/trusted.gpg.d/home:manuelschneid3r.gpg

1
0

I had the same issue. In my case, in the same directory /etc/apt/trusted.gpg.d I had .asc file just named differently. Once I renamed the .asc file by chaning its extension I was able to add Docker's gpg keys.

1
  • 1
    To be more precise, use this curl -fsSL https://download.docker.com/linux/ubuntu/gpg > /etc/apt/trusted.gpg.d/docker.asc
    – nagylzs
    Jul 10 '20 at 5:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.