I'd like to utilize my old netbook with the help of Kubuntu 20.04 to watch YouTube and write essays through "Google Documents."

After the Kubuntu installation, I tried to install chromium by using snap (candidate/vaapi) and proprietary nvidia-340 driver in order to enable hardware decoding.

During the installation of the Nvidia proprietary driver, I encountered the error:

nvidia-340 dpkg: error: version '-' has bad syntax: revision number is empty

By replacing KERNELS written in /var/lib/dpkg/info/nvidia-340.postinst file to CURRENT_KERNEL and subsequently executing dpkg-reconfigure nvidia-340, the problem was easily resolved. Thanks to Linux community.

Vapau hardware acceleration on VLC works well with low cpu usage.

However, in the case of Chrome, it was not as easy as before. It says on terminal like below.

[7873:7873:0601/140059.075024:ERROR:browser_switcher_service.cc(238)] XXX Init()
[8007:8007:0601/140103.101729:ERROR:vaapi_wrapper.cc(482)] vaInitialize failed: unknown libva error
[8007:8007:0601/140106.191463:ERROR:gl_context_glx.cc(227)] Couldn't make context current with X drawable.
[8007:8007:0601/140106.191708:ERROR:gpu_info_collector.cc(81)] gl::GLContext::MakeCurrent() failed
[8007:8007:0601/140106.191909:ERROR:gpu_info_collector.cc(208)] Could not create context for info collection.
[8007:8007:0601/140106.192123:ERROR:gpu_init.cc(66)] gpu::CollectGraphicsInfo failed.
[8007:8007:0601/140106.254424:ERROR:viz_main_impl.cc(159)] Exiting GPU process due to errors during initialization
[8119:8119:0601/140107.561057:ERROR:vaapi_wrapper.cc(468)] Could not get a valid VA display
[8091:7:0601/140107.821836:ERROR:command_buffer_proxy_impl.cc(125)] ContextResult::kTransientFailure: Failed to send GpuChannelMsg_CreateCommandBuffer.

And almost all of the "graphics feature status" in chrome://gpu/ has been changed to "software only, hardware acceleration unavailable".

And also chrome://gpu said:

Problem Detected

GPU compositing has been disabled, either via blacklist, about:flags or the command line. The browser will fall back to software compositing and hardware acceleration will be unavailable.

Disabled Features: gpu_compositing

I've googled around so much time, but I couldn't find a clear answer on the web.

I just guess it is related to libva (although I don't know what it is..).

The result of running vainfo is like below.

libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nvidia_drv_video.so
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

If anyone has experience in my situation, please give me feedback and shed a light on this.

A brief summary of my computer is as follows.

  • Operating System: Kubuntu 20.04
  • KDE Plasma Version: 5.18.5
  • Kernel Version: 5.4.0-33-generic
  • Processors: 4 × Intel® Atom™ CPU 330 @ 1.60GHz
  • Graphics: C79 Geforce 9400M/Ion
  • Thank you for correcting my post.
    – kayee EEK
    Jun 1, 2020 at 15:56
  • Update by myself. I found that "/usr/lib/x86_64-linux-gnu/dri/nvidia_drv_video.so" file didn't exist on my system. Based on "github.com/clearlinux/distribution/issues/1918", I installed the "libva-vdpau-driver". Now the vainfo is fine. But still, the error message of chromium is the same as before.
    – kayee EEK
    Jun 2, 2020 at 23:44

1 Answer 1


I got this to work on Ubuntu 20.04 by downloading the .deb file on https://launchpad.net/ubuntu/cosmic/amd64/vdpau-va-driver/0.7.4-6ubuntu1 and installing it. Either double click the .deb file or run sudo dpkg -i path/to/file.deb.

Specifically, it's the vdpau-va-driver_0.7.4-6ubuntu1_amd64.deb file under Downloadable Files section.

  • Thanks for your kind attention, and really sorry about the delayed reply. Actually, I completely forgot about this post, I'd like to say sorry again. I concluded the point of this problem as NVIDIA driver-related, not the Linux system itself. I've already installed the package before your suggestion and tried to do some more things(Although, I couldn't clearly remember). But still, I couldn't reach a better situation. Even the end of life(EOL) of my graphics driver passed a few months ago. So it seems to be the situation will not be better.
    – kayee EEK
    Mar 18, 2021 at 7:53
  • Instead, I have circumvented this problem by installing the chrome extension "Open in VLC", Although some streams couldn't play properly, during several months of experience of using it, I'm pretty well satisfied with that. I'd like to close this problem with say thanks to all you guy's interested in my difficulty.
    – kayee EEK
    Mar 18, 2021 at 7:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .