0

My goal is to update my ubuntu 19.04 system to 20.04 LTS as the support faded out. I have prepared the newer os as a live system on a stick. As I have had problems with this particular hardware configuration of my laptop and linux earlier, I am trying to get the live system up and running before starting the actual installation. Without any changes of grub parameters, the system would not boot at all. With acpi=off it does. However, the touchpad does not work and also shutting down is problematic (which is less of an issue). I tried booting my old 19.04 system with acpi=off as well (even though it works without) for testing purposes. The same issues regarding touchpad and shutdown ensue. How can I make the touchpad (and ideally also the shutdown) work?

xinput on my old system yields the following information regarding the touchpad:

FTCS1000:00 2808:0101 Touchpad              id=11   [slave  pointer  (2)]

The /proc/bus/input/devices file lists the touchpad in the following way:

I: Bus=0018 Vendor=2808 Product=0101 Version=0100
N: Name="FTCS1000:00 2808:0101 Touchpad"
P: Phys=i2c-FTCS1000:00
S: Sysfs=/devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-0/i2c-FTCS1000:00/0018:2808:0101.0001/input/input21
U: Uniq=
H: Handlers=mouse0 event15 
B: PROP=5
B: EV=1b
B: KEY=e520 10000 0 0 0 0
B: ABS=260800000000003
B: MSC=20

When booting with acpi=off (on either system) both methods will not show any touchpad, so I figure it is not even recognized by the system in this case. The 19.04 version uses the 4.18.0-25-generic kernel. 20.04 LTS uses the more recent 5.4.0-26-generic kernel. I have also tried a couple of other common recommended grub parameter changes like e.g. adding noapic, nolapic or nomodeset. None of it seemed to help. Furthermore I tried creating the installation medium in various ways: with the startup disk creator utility of ubuntu and also from within Windows (10) with both win32 Disk Imager and Rufus in different configurations. I have not used plain ubuntu in all attempts, as I am ultimately aiming at installing xubuntu. Still, both yielded the same results which seems plausible as I figure the desktop environment probably has nothing to do with this rather low level issue.

Any help is welcome. Let me know about any additional information you need.

1 Answer 1

0

I was/am having a similar problem with a Clevo NL51LU on 20.04. I think it might (also?) be an ELANTECH touchpad. The workaround for me was to add pci=nocrs flag to the kernel boot grub line. See ELAN Touchpad not working on Lenovo IdeaPad with Ubuntu 16.04 (the i8042 parameter isn't needed).

There's a kernel bug opened about this, indicating the problem might be in the machine bios, if you are seeing a "failed to claim resource" message in your kernel log - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1884232

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .