9

I am very impatient, when I unfortunately mistype my login-password on my laptop (Ubuntu 20.04), I don't want to wait three seconds to retry. (A delay of 0.3 seconds would be enough to prevent potential brute force and there is a longer time after 3 failed attempts anyway.)

I found a lot of answers explaining how to change this delay for the console login and for sudo. I managed to set that delay to 0.3 seconds by editing the value in /etc/pam.d/login (for the tty console) to:

auth       optional     pam_faildelay.so  delay=300000

and adding the same line to /etc/pam.d/common-auth (for sudo and the graphical login screen) as first line before (!) this line:

auth    [success=1 default=ignore]      pam_unix.so nullok_secure nodelay

See:

This kind of changes the delay that occurs on the graphical gdm3 login-screen in Ubuntu 20.04 but only until the login input field reappears (and shakes). If you set a long delay in /etc/pam.d/common-auth, it counts only for the time before the input field reappears. It has no effect on the delay after the shaking.

I already activated logging in gdm and this is the output of grep gdm3 /var/log/syslog when I pressed SUPER+L to Lock screen and tried about 6 times a false password; you see the 3s delay in the attempt. At the end of each false password attempt, there is a log:

reauthentication service 'gdm-password' stopped

after this there starts the 3s delay until I get a new cursor. Maybe this is the main problem?


Update:
For info: I use GNOME Shell 3.36.1. An Idea of mine was maybe disable the shaking animation will help? Because I found out, that you can use the mouse to click into the field and you can type immmediately while the box is shaking.

8
  • 2
    You really shouldn't lower the delay. It's there to make brute-force attacks on your system less effective. Take your time, try to type the username and/or password correct the first time, or relax the little time it takes. Security has its costs. – Soren A Jun 2 '20 at 0:23
  • @rubo77 yes, but you need both changes at the same time. Remove the default delay and add a custom one, if you want to express it like this, instead of changing it. – Byte Commander Jun 15 '20 at 1:56
  • I guess it has to do something with the focus being set to the input field for the password in an unfortunate manner. Is the login screen programmed in html with CSS? – rubo77 Jun 15 '20 at 17:51
  • if you are concenred about brute forcing then just set retries to 20 , you are unlikely to typo that many times – Amias Jun 16 '20 at 13:01
  • I think what @ByteCommander meant was to disable the original using nodelay and type in your own custom line instead. Also, when you are addressing a fairly busy user, especially a mod, @ to ping them or your reply will most likely go unnoticed. You probably know this as you are an experienced user. I assume you forgot that time? – Sasuke Uchiha Jun 19 '20 at 15:43
2
+50

After a lot of digging into the gnome-shell and gdm source code, the problem seems to have been fixed by these two commits:

These fix the issue where the input box doesn't get focused for 3 seconds after the shaking stops.

These changes are there in Gnome 3.36.2, and updating to that version fixes the issue. Now you can type even while the box is shaking.

To disable the shaking see @PRATAP's answer.

8
  • seems this is the perfect fit.. can you also include the steps how to update to the version 3.36.3 – UnKNOWn Jun 20 '20 at 7:02
  • @PRATAP Ubuntu 20.04 has an update for Gnome 3.63.2, which fixes the issue according to OP rubo77 (looks like just 3.63.2 is enough), so just sudo apt update && sudo apt upgrade. – ashvatthama Jun 20 '20 at 7:05
  • I'm finding that the problem still exists with 3.36.3 and Ubuntu 20.04 LTS. (@ashvatthama I think you have a typo in the version number in your previous comment.) – Courtney Miles Jul 23 '20 at 22:56
  • @CourtneyMiles hmmm... could you post the outputs of gresource extract /usr/lib/gnome-shell/libgnome-shell.so /org/gnome/shell/ui/components/polkitAgent.js and gresource extract /usr/lib/gnome-shell/libgnome-shell.so /org/gnome/shell/gdm/authPrompt.js please? – ashvatthama Jul 24 '20 at 4:05
  • @ashvatthama polkitAgent.js - pastebin.com/EkY2nrgy / authPrompt.js - pastebin.com/AcqB3Qhs -- Thanks for taking a deeper look at this. – Courtney Miles Jul 25 '20 at 23:28
1

Workaround based on the update in the Question

An Idea of mine was maybe disable the shaking animation will help? Because I found out, that you can use the mouse to click into the field and you can type immediately while the box is shaking.

Shacking animation can be disabled if you wish to stop the global animation by running the below command for the desktop session..

gsettings set org.gnome.desktop.interface enable-animations false

The above command helps for the lock screen..

enter image description here

If you wish to disable the shacking animation for the login screen too.. run the below command..

sudo -Hu gdm dbus-launch gsettings set org.gnome.desktop.interface enable-animations false

for reverting above changes..

gsettings set org.gnome.desktop.interface enable-animations true

and

sudo -Hu gdm dbus-launch gsettings set org.gnome.desktop.interface enable-animations true

Tested in Ubuntu 20.04 for both lock and login screens..

3
  • Nice, I didn't know you could disable animations that way. Also how did you manage to screen record the login screen? – ashvatthama Jun 20 '20 at 5:58
  • 2
    @ashvatthama no, thats not the login screen.. It is lock screen.. that means you are still in your session.. so what ever the tool you use to record.. it works.. – UnKNOWn Jun 20 '20 at 7:03
  • I didn't know that, thanks. I'll try to include a screen recording in my answer as well now. – ashvatthama Jun 20 '20 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.